Unable to locate configuration File

  • Man, what an odd turn of events. I came back from a 2 week vacation at work, only to find that my server:
    (1) Was “unable to connect to TFTP server”. Fixed that by a couple of reinstalls of FOG until I got it right.
    (2) Attempted to UPLOAD an image, and recieved an “Unable to locate configuration file” message.

    I boot off of CDROM using iPXE, which worked from August until now. Here’s basically what my boot looks like. This is not my actual, but an example copied from elsewhere that is the same…

    PXELinux 3.82 2009-06-09
    . . . [other informations]
    !PXE Entry point found (we hope) at 9D3B:0109 via plan A
    UNDI code segment at 9D3B len 16C2
    UNDI data segment at 933B len A000
    Getting cached packet 01 02 03
    . . . [other informations]
    TFTP prefix:
    Trying to load: pxelinux.cfg/ec5db4c0-74fe-d511-b9e7-3d9235afe5a1
    Trying to load: pxelinux.cfg/01-00-17-31-b6-5e-a8
    Trying to load: pxelinux.cfg/0A64491E
    Trying to load: pxelinux.cfg/0A64491
    Trying to load: pxelinux.cfg/0A6449
    Trying to load: pxelinux.cfg/0A644
    Trying to load: pxelinux.cfg/0A64
    Trying to load: pxelinux.cfg/0A6
    Trying to load: pxelinux.cfg/0A
    Trying to load: pxelinux.cfg/0
    Trying to load: pxelinux.cfg/default

    Unable to locate configuration file
    Boot failed: press a key to retry or wait for reset

    Seems to load pxelinux.0 OK, but then stalls every time. My IP hasn’t changed,
    and otherwise FOG seems fine.

    Any suggestions?
    Thanks in advance,

  • FYI, here are the lines I had to add to the iPxe config to deal with the other TFTP image server on my school network:

    #already had this line in place
    set next-server 10.xxx.xxx.xxx

    #additional lines to make sure correct boot image and image server are used
    set filename pxelinux.0
    set proxydhcp/filename pxelinux.0
    set proxydhcp/next-server 10.xxx.xxx.xxx

  • Well, it only took 3 months, but I’ve solved this one… or at least I know what the problem is.

    I was using iPxe CDROMs for the machines that connect to the FOG server. I do this because my school district isn’t “friendly” towards my FOG server, and won’t let me make any sort of changes to the network, or have my own DHCP server.

    iPxe worked great until December/January. I went away for two weeks, then came back to a non-working FOG server. Specifically, I could not UPLOAD images to the FOG server any more.

    Today, after playing with iPxe for a few hours, I noticed that the config utility was showing a “second” TFTP server on the network with a different IP and a different default “filename” setting than mine. Basically, while I was setting iPxe correctly, some of the config settings from the “other” TFTP server on the network were being mixed in with my iPxe settings.

    I was logging into my FOG server OK, TFTP was working OK, the FOG server is configured OK, but when it came time to grab “config.cfg”, everything fell apart. Unknown to me, I was trying to grab config.cfg from the OTHER TFTP SERVERS directory structure somehow.

    SOLUTION: I will have to add additional iPXE “set” or “clear” commands to make sure the settings from the other TFTP server are not in place before booting the pxelinux.0 image.

  • Thanks BryceZ…

    Yea, I have considered rebuilding the server. I may have to if I can’t solve this soon.

    I’ll comb the configs one last time, and 777 everything and see if that helps. If not, I have an old backup that dates to WAY before the issues started, so I may have to spend a day and rebuild everything. The sad part is that it worked great, I left for two weeks, and now it’s hosed.

    Another concerns is that the district I work for controls the network infrastructure, and they may have changed the switches or DHCP server or something.

    Another option would be to build a box just for FOG.

    Anyway, thanks for two helpful responses 🙂

  • Your issue is definitely a strange one that I have not encountered… much as I hate suggesting it, have you tried rebuilding the server from scratch?

    A terribly not secure test would be to blast away all permissions on /tftpboot/ with something like chown -R fog.root /tftpboo/ && chmod -R 777 /tftpboot/

    Another thing to consider would be to check the following configs:
    tftpconfigupstartconf="/etc/init/tftpd-hpa.conf" (Ubuntu only)
    tftpconfigupstartdefaults="/etc/default/tftpd-hpa" (Ubuntu only)

  • Can anybody point me to documentation on checking for configuration issues? Any sort of list as to what folders I should check?

  • Ok, I’ve been messing with this for a couple of months now, and I still can’t get it to work. I’ve put off imaging my lab multiple times. I’m getting a bit desperate here 🙂

    • I’ve reinstalled FOG multiple times, deleting anything that even remotely has FOG written anywhere on it.
    • I’ve tested TFTP from a Windows box with the FOG user, it works fine, pxelinux.0 is visible, etc.
    • I’ve tested FTP from a Windows box with the FOG user, it works fine, the “default” config file is visible, etc.
    • The Fog server is installed fine, all is well. I can create tasks and they show up in the tftpboot folder with the proper MAC address associated with them.

    And yet, I still get the “unable to locate configuration file” error, over and over.

    ANY suggestions, any stab in the dark, anything… I’m getting to the point where I will have to revert to Clonezilla to get this lab imaged. Is there a listing of what the file permissions should be that I can compare to?

    Here’s what I have:

    /tftpboot$ ls -lR
    total 216
    -rw-r–r-- 1 fog root 828 2012-02-12 12:02 boot.txt
    drwxr-xr-x 5 fog root 4096 2012-02-12 12:02 fog
    -rw-r–r-- 1 fog root 25340 2012-02-12 12:02 memdisk
    -rw-r–r-- 1 fog root 16794 2012-02-12 12:02 pxelinux.0
    drwxr-xr-x 2 fog root 4096 2012-02-12 12:19 pxelinux.cfg
    drwxr-xr-x 2 fog root 4096 2012-02-12 12:02 tftpboot
    -rw-r–r-- 1 fog root 147728 2012-02-12 12:02 vesamenu.c32

    total 68
    -rw-r–r-- 1 fog root 8435 2012-02-12 12:02 bg.legacy.png
    -rw-r–r-- 1 fog root 44908 2012-02-12 12:02 bg.png
    drwxr-xr-x 2 fog root 4096 2012-02-12 12:02 images
    drwxr-xr-x 2 fog root 4096 2012-02-12 12:02 kernel
    drwxr-xr-x 2 fog root 4096 2012-02-12 12:02 memtest

    total 6392
    -rw-r–r-- 1 fog root 6530155 2012-02-12 12:02 init.gz

    total 10984
    -rw-r–r-- 1 fog root 11227312 2012-02-12 12:02 bzImage

    total 168
    -rw-r–r-- 1 fog root 164504 2012-02-12 12:02 memtest

    total 8
    -rw-r–r-- 1 fog fog 424 2012-02-12 12:19 01-00-23-ae-8b-78-32
    -rw-r–r-- 1 fog root 2168 2012-02-12 12:02 default


  • Some tftp servers use /var/lib/tftpboot as home, try copy the files there and see if your client can find them.

    Thanks… tried that but it didn’t work.

  • Some tftp servers use /var/lib/tftpboot as home, try copy the files there and see if your client can find them.

  • You will need to look harder.

    Fair enough, I will look harder…

    However, I only came here after reinstalling FOG 3 times, tweaking the FOG user passwords multiple times, changing paths many times, and changing permissions on multiple folders multiple times. So I’ve been trying pretty hard to solve this issue on my own 🙂

  • Developer

    It looks like a configuration issue. i.e. service looking in the wrong directory, paths are wrong, going to the wrong server?

    BryceZ has given good information. You will need to look harder.

  • Thanks for the reply. I already have a task in place, and it is showing up properly as a file named with the MAC Address of the machine. The config file is in place also. I guess I’m going to have to go over the permissions with a fine toothed comb and try different things. Attached is a screen shot showing the folder/files/permissions for default on my Ubuntu machine.


  • Check /tftpboot/pxelinux.cfg/default on the FOG server. Make sure the file is there and correct. It sounds like it’s accessing the TFTP server but cannot find or read the default config file, either because it doesn’t exist or maybe a permissions issue. A quick test would be to create a debug task for one of your hosts. Whenever the FOG server creates a task it writes a host specific config file, so when the client boots it wouldn’t need to look for the default config because it would have it’s own. If that doesn’t work then check the permissions higher up on the directory structure to make sure that it’s not locked down in some way that prevents access to the /tftpboot/pxelinux.cfg/ directory.