Error deploying image captured after FOG upgrade



  • Hi All,

    Recently upgraded from FOG 1.4.3 to 1.5.4 and have had a few teething issues.

    Since the upgrade we captured an updated copy of an image which seemed to capture fine (although now I think of it, I haven’t watched the final stage of the capture to see if there were any issues).

    Upon deploying this image it is failing at the “Restoring Partition Tables (GPT)” stage with an error trying to restore GPT partition tables (see screenshot attached).

    Older images are still deploying fine, even to the same laptops that we are testing with.

    I have already tried rolling back the FOS kernel from “4.16.6” to “4.15.2” as per some instructions from another forum post I created about a separate issue, however this has not changed anything and I get the error on either version.

    Any ideas? Any help you can provide would be much appreciated!

    Thanks, Derek0_1530775831993_FOG_GPT_Error.png



  • @Quazz

    Unfortunately we have overwritten the original problematic image with a test image so the ‘cat’ commands won’t be of any use at this stage.

    The test images we have been doing appear to be working fine so we are just going to rebuild our image and hope that fixes our issue!

    I’ll post back on here if we continue to have this trouble.

    Thanks everyone!


  • Moderator

    @derek-newbold What’s the output of

    cat /images/STAFFIMAGE-WIN10/d1.fixed_size_partitions
    
    cat /images/STAFFIMAGE-WIN10/d1.minimum.partitions
    
    cat /images/STAFFIMAGE-WIN10/d1.partitions
    


  • @Tom-Elliott we have tried resizing the windows partition to be a lot smaller than the target laptops hard drive, recaptured the image which appears to be all successful during the capture process, didn’t see any errors and it appears to be resizing the partitions OK before capturing. It is still not deploying the image successfully though, comes up with the error about GPT partition tables.

    Have tried running “chkdsk /f” on Windows before capturing the image as I believe that fixed an issue I had in the past with images not getting resized correctly. This didn’t make any difference either.

    Any images that were captured prior to the FOG upgrade are still deploying OK.

    Any further ideas please?



  • Can you confirm that you successfully downgraded the FOS kernels?

    @george1421 Yes, I used these commands to confirmed that it worked when I downloaded them. They both say version 4.15.2. I assume you do not need to restart the FOG server after downloading the new kernels?

    is the target drive smaller than the original drive?

    @Tom-Elliott Possibly slightly smaller, however it is strange as this image was built for these laptops and it was working before we upgraded FOG and recaptured an updated version of the image. We are also using the “Single Disk - Resizable” option so normally that handles smaller drives as well? Maybe it’s not shrinking the image properly, I think I may have had issues with that in the past but can’t quite remember how we got around it hmm…

    I will try resizing the Windows partition of the VM that we are capturing and see if that makes a difference.


  • Senior Developer

    @derek-newbold is the target drive smaller than the original drive? I’ve seen similar issues with gpt because of this. There’s also the possibility the sector sizes are different between the two. We haven’t quite figured out a mechanism for this yet so this could also play a part.


  • Moderator

    Can you confirm that you successfully downgraded the FOS kernels?

    Follow this process

    cd /var/www/html/fog/service/ipxe
    file bzImage
    file bzImage32
    

    The file command will tell you the version of the kernels.


 

507
Online

41.6k
Users

12.1k
Topics

114.3k
Posts