Surface Pro 4 with new Dock, no PXE boot



  • So I’ve got a weird one. It seems that FOS doesn’t see the NIC on a Surface Pro 4 using:
    Fog Server Version 1.5.4
    bzImage details:

    file bzImage
    bzImage: Linux kernel x86 boot executable bzImage, version 4.10.10 (root@debian64) #1 SMP Sat Apr 15 13:21:35 EDT 2017, RO-rootFS, swap_dev 0x7, Normal VGA
    

    SP4 updated to latest firmware.

    Any suggestions?

    Running udhcpc from within FOS just kinda sits there sending discovers, eventually gives up. Where are the logs located that would help track down this issue? I didn’t see anything interesting in /var/log while booted into FOS


  • Moderator

    @svalding What would be interesting to know is what is different between the two docks.

    Please do the following

    1. Schedule a debug deploy/capture (tick the check box for debug before you submit the task) for the nic of the working dock. It doesn’t matter if its a capture or deploy because we are not going to do either.
    2. PXE boot the target computer, after FOS boots you should see several screens of text press enter a few times until you get to the linux command prompt.
    3. Key in
      lspci -nn | grep etwork
    4. Record what you see there for the network adapter. The hex codes are important.
    5. Repeat the same process with the non-working dock. You may get warning messages about not able to access the network, but it still should allow you to get to the linux command prompt.
    6. Collect the output of the lspci command from above.
    7. Please post the output of those two systems in this thread.


  • I tried with a different dock, and everything worked without any issues whatsoever. It was the same “style” of dock (the new brick style ones). Not sure if a chipset changed inside them or what, but that did the trick for this issue.




Log in to reply
 

477
Online

5.9k
Users

13.3k
Topics

125.1k
Posts