PXE Boot Dell Optiplex 7050 fails in UEFI works in Legacy



  • I have only had FOG going for 24 hours… Please make no assumptions about what I might know ;)
    CentoOS 7 running in Hyper-V
    Server 2016 domain running dhcp
    Network has multiple V-lans but has been running in the current configuration for 5 years
    Juniper network - setup by a Juniper Senior Network Engineer.

    FOG trunk updated on 06/07/208 1.5.4
    Currently running Kernal 4.17.0 Tom Elliot 64

    Optiplex 7050
    Current Bios 1.8.3
    Built in Intel NIC

    The system will not PXE boot with UEFI enabled
    Bios settings: enable legacy Option Roms, checked - UEFI Boot Path Security, Never - Secure Boot, Disabled - UEFI Network Stack is Enabled w/PXE

    DHCP server option 67 - undionly.kpxe have also tried undionly.kkpxe
    Currently the machine is on the same vlan as the server - but not the same physical switch (Juniper EX4200 )

    Please help!



  • @george1421 I have had to disable secure boot to PXE boot at all with FOG, but I think you can re-enabled it after the image deploys but before it starts the OOBE experience (meaning you will need to have it shut down after imaging or catch it on reboot). One of the more experienced guys might prove me wrong though.
    You will have to leave it disabled if you want to PXE boot in the future though.



  • @dholland When we started rolling out the 7050 and the lattitude e5580 we were forced to go Windows 10 thanks to Intel not supporting updates in Win7 with their latest chipsets, so I had to figure out making a golden image for Win10, using UEFI and Legacy on same network… all sorts of fun.


  • Moderator

    Security down grades? You mean disabling secure boot? That is required since the iPXE kernels are not signed by microsoft.

    Yes you found that bios (legacy) systems use undionly.kpxe and uefi systems need a uefi boot file ipxe.efi.

    Since you have a windows (current) dhcp server be sure to follow the guide @jflippen linked to provide dynamic switching between uefi and bios boot files.



  • @dholland
    After all that - those settings and dhcp image file of ipxe.efi works

    I had not tried it with all the other security downgrades… Just takes posting to find the answer!



  • @dholland Hey, I think for UEFI booting you have to boot with ipxe.efi for option 67. Also, I would give this wiki page a read… I just set it up last month and it’s amazing!
    https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence


 

409
Online

41.6k
Users

12.1k
Topics

114.4k
Posts