FOG Interface Completely Unresponsive



  • @george1421

    After re-uninstalling PHP and reinstalling FOG to try and correct some lag issues and unresponsive interface, FOG php interface is completely not working. I have tried creating a php info page and running that and that does not run.

    Any suggestions are helpful.



  • @george1421
    As always, I appreciate the help! I am happy to help out where I can.


  • Moderator

    @joe-gill Ah OK, when you get back to it, we may need to up the memory settings in php-fpm since the php.ini settings are ignored by php-fpm. Understand we are still tuning the php-fpm settings. We need real world feedback to get the most appropriate settings for everyone.



  • @george1421
    Yes php-fpm is off currently. I am going to leave it that way for a bit. I may play with it more later this Summer but for now I’m leaving it turned off.

    What would happen with mine, when php-fpm was turned on, was it would appear to be working OK and then bomb out when I ran a multitask session. Most of the time, if I ran a single task here and there, things would be OK. As soon as I threw something that was memory intensive, things would crash.

    Glad we’re up and going again. I imaged two labs and didn’t have any problems with FOG.


  • Moderator

    @joe-gill so you disabled php-fpm and its OK? In the other thread the OP there has sluggish responses, but php-fpm was not enabled on his system and he had Debian 9.4 installed. Once I turned it on, then his web ui started responding normally.

    If its working for you now, then we’ll just hold off making any changes.



  • @george1421
    It is Debian 9.4.

    And so far everything is working just fine since the change. I’ll let you know as time goes. But so far so good!

    Thanks again!


  • Moderator

    @joe-gill Is your fog server debian based?



  • @george1421

    I have several tasks I will be running this afternoon. I will report back as to whether this fixed things. Previously, the issue would come back and haunt me after more than one multitask session.

    Thank you for the help!!!



  • As soon as I commented out the setting in SItes-Available, things worked.



  • @george1421

    So… I after re-install things were still not happy. I got things back up to 1.5.4 and checked out the SetHandler settings. In Sites-Available, the setting was not commented out. In Sites-Enabled, it was commented out. As soon as I did that and re-started Apache, things came back up. I then checked the setting for FOG Client Check In Interval and it was set to 60. I upped that to 300.

    Note - As soon as I restarted Apache, I had a multicast session that was stuck in tasking before all of this happend. That task took off and began imaging. So far so good!


  • Moderator

    Once you are back on 1.5.4, then navigate to /etc/apache2

    Then we need to search for the php handler, so key in the following line
    grep -R -e "127.0.0.1:9000" *

    You should see the file where this line exists.
    Now edit that file and search for
    and move the comment from this

    #SetHandler application/x-httpd-php
    SetHandler "proxy:fcgi://127.0.0.1:9000"
    

    to this

    SetHandler application/x-httpd-php
    #SetHandler "proxy:fcgi://127.0.0.1:9000"
    

    Save and exit your text editor
    Then restart apache
    run the info.php url I mentioned in the other thread. Now your setting should look like this:
    0_1528396953283_php-apache.png

    See if that reacts any differently.


  • Moderator

    Interesting, you are back on 1.5.1 now and performance still is bad?

    Lets take it back to 1.5.4, then we are going to shut off php-fpm to see if that is causing an issue for some reason.

    Again for clarity, what do you have set for fog client check in interval?



  • So I have gotten the PHP interface back up and running. To get this back online, I had to run the 1.5.1 version of FOG. The interface was up long enough for me to log in and then it bombed out and is now un-responsive again.


 

452
Online

41.9k
Users

12.5k
Topics

117.6k
Posts