Stuck on iPXE Initializing Devices



  • Fog 1.5.3
    Centos 7

    I have one specific model of computer that is getting stuck on iPXE Initializing Devices. It is an HP Prodesk 400 G1. All my other models are currently working. The weird thing is, we imaged about 40 of these a month ago without issue. I’m running FOG on a VMWare vSphere server. I’m using undionly.kpxe and have also tried undionly.kkpxe with no success. I updated the kernel to 4.16.6. Any help would be appreciated!



  • Upgrading the firmware worked!!! No idea what has changed in the last month, but I am just glad for a fix. Thanks for your help!


  • Moderator

    @jclumbo33 OK SO… its probably not ipxe that is causing things to stick, but the target system because we’ve kind of ruled out any changes to iPXE kernel or FOG since 1 year ago.

    Would you ensure a firmware update does not address this?

    It would be interesting to know what is different between the 400 G1 and others that do work.



  • Still no luck, it hangs in the same spot. I appreciate your help, I was hopeful on that one.


  • Moderator

    Interesting 2 months ago it worked and you were on 1.5.2 , and now it didn’t work, you upgraded to 1.5.3 and it still doesn’t work.

    OK lets try rolling back undionly.kpxe back to 1.4.4 version.

    On your FOG server change into /tftpboot
    cd /tftpboot
    Rename your existing undionly.kpxe to a save file.
    sudo mv undionly.kpxe undionly.kpxe.sav
    Now copy in the 1.4.4 undionly.kpxe into the /tftpboot directory. (look at your fog forum chat bubble)
    Now ensure that you update your dhcp server to send out undionly.kpxe as the FOG boot file.

    Lets see moving back to 1.4.4 version of iPXE does anything different.



  • I was on 1.5.2 when it last worked on those machines. I actually updated to 1.5.3 today to see if that would solve the issue, so it didn’t work on either version.

    It doesn’t get to that point, it stops right before it. Here’s a screenshot of where is hangs:

    0_1528133667001_20180604_132313.jpg


  • Moderator

    @george1421 OK my memory is not so good, it was parentheses not squared brackets. In this case the number is 356f.

    0_1528131121427_pxe_boot.png


  • Moderator

    @jclumbo33 What version of fog were you using 1 month ago?

    Sorry, second part. When you pxe boot a target computer it displays ipxe banner on that banner there is a hex code in square brackets. Can you post what that code is?



  • I’ve tested it from a cold boot with no success and on a few of the same machines that worked a month ago. Yes the machines are in legacy mode. I have not updated the firmware, could this be the issue even though it previously worked?


  • Moderator

    @jclumbo33 two things.

    1. The kernel is not at issue just yet. This is in the iPXE realm. (ipxe starts the kernel [bzImage], but you need to see the iPXE FOG menu first).
    2. Test by starting the computer from a cold start not a reboot.

    I take it this computer is in legacy (bios) mode? Is the firmware up to date on this unit?



  • No luck with ipxe.pxe. Got the same result, stuck on initializing devices. Think downgrading the kernel would have any effect?


  • Senior Developer

    Can you try using the ipxe.pxe file? I’ve seen hp machines act wierd due to the kernel doing something with firmware on the nic, and windows doing something else. By using ipxe.pxe it helped fix that strange issue for me.


Log in to reply
 

514
Online

6.2k
Users

13.6k
Topics

128.3k
Posts