Accidentally set main FOG user to mobile access only! - Solved



  • Let me first start off by saying that I love using FOG for imaging the computers at my work. It has saved us a great deal of time and I have been able to stream line our imaging process with the use of adding the computers to AD, as well as adding printers. I was exploring all of the other features when I decided to look into the mobile set so our techs could image computers on the fly.

    So I decided to add a new user called ‘mobile’ but I had to walk away to take care of another issue with a user and when I came back the FOG server had automatically logged me out of the site. I logged back in and without even thinking, I clicked on our main user account instead of making a new user. I then clicked mobile access only and save. :(

    I didn’t realize what I had done till my coworker said that he could not get back into the main site. I thought it was something he was doing because I was still logged in at the time so I logged out. When I tried to login it gave me no indication that anything was wrong because it just returned me to the login page. I rebooted but that did not fix it. I thought maybe MySQL was down, checked the service and it was running. Checked the username and password in the config.php files and they were all correct. At this point I was thinking WTF is going on?!?!?!?!?!

    Then it hit me like a ton of bricks when I realized that I could still access the mobile site. I also realized that we did not have any other accounts that had admin rights. S!$T!!! Since I was not able to login to the fog website I couldn’t create an account either to change that setting.

    At this point, I was freaking out because I didn’t want to have to rebuild the entire fog server because I was still able image computers and access the PXE menu with the computers. So to save you the trouble if you ever run across this situation as I did, here are the steps I did to resolve this issue.

    [LIST=1]
    []Logged into the FOG server via SSH using the putty program
    [
    ]Installed phpmyadmin via apt-get, the command is [B]sudo apt-get install phpmyadmin[/B]
    []Logged into phpmyadmin at [B][url]http://fogserverip/phpmyadmin[/url][/B]
    [
    ]Clicked on the [B]“FOG”[/B] database on the left hand side to access the rows in the database
    []Clicked on the [B]“users”[/B] section on the left hand side which should open all of the users that were created with FOG
    [
    ]Clicked on the [B]“Edit”[/B] button which looks like a pencil for the user that needs to have mobile access only removed
    []I then went to the field called “uType” which was set to [B]“2”[/B]. I then changed that to [B]“0” [/B]and clicked on the button at the bottom of the page called [B]“GO”[/B]
    [
    ]Went back to web interface and I was able to log back as usual.
    [/LIST]
    **Note that you the user that you log in with on phpmyadmin is a MySQL user and needs to have rights to the FOG database, otherwise it will not show up in phpmyadmin.

    I have now created another admin account so I do not run into this same situation again but I hope this helps somebody out because I know how frustrating these sort of problems can be.



  • I didn’t know about the mobile site.
    I should say users can logon to mobile site with no problem.
    Thanks



  • [quote=“sid, post: 2923, member: 558”]Hello

    That’s funny that you made the fog user into a moblie and I can’t log in with any mobile user that I create.
    fog is keep going back to login screen when I use the mobile user to login with.
    may I ask which version of FOG are you using and if you ever experienced the issue that I have with mobile users?

    Thanks[/quote]
    I am using the latest version Fog 0.32. I know you will not be able to login to the main management site with a mobile user. You should be able to use either a regular user or mobile user on the mobile site.

    Which page are you trying to login to with the mobile user?



  • Hello

    That’s funny that you made the fog user into a moblie and I can’t log in with any mobile user that I create.
    fog is keep going back to login screen when I use the mobile user to login with.
    may I ask which version of FOG are you using and if you ever experienced the issue that I have with mobile users?

    Thanks



  • This post is deleted!

  • Developer

    Good work. I will be moving this to the ‘How-To’ section.


Log in to reply
 

370
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.