Erasing current MBR/GPT tables.... taking about 5-10 minutes



  • Fog serveur : 1.5.3 on ubuntu 17.10 amd64

    Hi,

    I’ve upgraded today my fog server from 1.5.0 to 1.5.3. I’ve got no issue and everythings works just fine.
    Except the part where fog erases partition tables… I mean it works but it takes about five-ten minutes for doing it.
    Before upgrading i don’t know how much times it took but i’ll say about a few second.

    Any idea ?


  • Developer

    @Lemeunier @andreiv @benc @matijn @dbettens @MCSDFog @JGallo @jclumbo33 @luco60 Good news to all of you, we have figured out what is causing the slowness and fixed it. It’s been a longer story [ref] - thanks again to @Quazz for doing lots of testing and finding very helpful stuff to figure this out!

    As we have not had enough time to push for a new release yet you can simply update to the latest kernel and inits like this:

    sudo -i
    cd /var/www/fog/service/ipxe
    mv bzImage bzImage.orig
    wget https://fogproject.org/kernels/bzImage
    mv bzImage32 bzImage32.orig
    wget https://fogproject.org/kernels/bzImage32
    mv init.xz init.xz.orig
    wget https://fogproject.org/inits/init.xz
    mv init_32.xz init_32.xz.orig
    wget https://fogproject.org/inits/init_32.xz
    


  • @Quazz Sure, I understand. Thanks for the solution. I replaced the kernel and it works perfectly.


  • Moderator

    @andreiv Use kernel 4.15.2 for now.

    A lot of work has gone into tracking down the source of the problem, which we believe we have found. Now it’s just a matter of formulating a fix for it and getting it pushed.

    People are quite busy though, so unsure when that’s going to be, but it is being worked on still.



  • This issue is still there in 1.5.4. It isn’t a real problem as much as it is an annoyance.



  • @george1421 Thanks, I will give that a try later today.


  • Moderator

    @benc Its under fog settings -> kernels. Roll back your current kernel to 4.15.2 until the developers can get the issues with the current linux releases sorted out. You will need both the 64 bit and 32 bit kernels when you download them.



  • Please forgive my ignorance, but could someone point me to a guide on how to change kernels? I’m pretty sure I understand at least at a basic level what the kernel is and what it does, but I’ve never done this before and the googling I’ve done on installing new kernels has only confused me. In my case the step where FOG erases the MBR/GPT tables is taking 6+ minutes which is longer than the actual imaging process takes. As soon as I get past this current batch of laptops that must be imaged ASAP, I’ll be starting from scratch with a new hard drive in one of my fog servers and probably starting with Ubuntu Server 14 and not going any higher. So far, in my experience, upgrading one thing breaks other things and it just snowballs from there. Sorry for the long post but this has been a very difficult day.



  • I want to add to the above.
    You need to chmod 777 rights to /var/www/fog/service/ipxe , for succesvol installing (overwrite) another kernel.
    Can confirm 4.15.2 (32 + 64) kernels are instantly doing ‘Erasing current MBR/GPT tables’ !

    FTP incorrect error, check:
    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    Credentials / Passwords
    There are a few places where all the credentials (on a standard install) should match exactly.
    Web Interface -> Storage Management -> [Your storage node] -> Management Username & Management Password
    Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD
    All of those should match (again, on a standard installation).
    /opt/fog/.fogsettings (password in plain, should match)

    FTP upload class fix:
    chown fog -R /images
    chmod -R 777 /images



  • I had the same problem with a fresh install on unbuntu18.04 running fog 1.5.3
    as suggested i downloaded the kernels from a previous version, i used 4.14.4 (both 64 & 32bit) and this fixed the issue too



  • @tom-elliott At this point I stayed on 1.5.3 and I ran tests with three different kernels. 4.16.6 and 4.17.0 behaved similarly. They both took over 4 min to finish Erasing MBR/GPT. With kernel 4.15.2 the Erasing MBR/GPT took about 1 sec.


  • Senior Developer

    @lemeunier that’s a totally separate error, can you please open a new thread, or search for the similar error and see if those suggestions help.



  • @tom-elliott I try to download it but… I’ve got this error : Error: Download Failed: Failed - filesize



  • Looks like formatting is much faster now using kernel 4.17.0 vs previous kernel. Thank you @Tom-Elliott I hope others have same experience. I must also add that I’m on Ubuntu Server 16.04 and FOG 1.5.4



  • @tom-elliott I’m going to upgrade right now. I can try it and check back.


  • Senior Developer

    Anybody mind downloading the latest 4.17.0 kernels?

    I’ve added back patch that I haven’t had to do in a while, hopefully it can help fix the slowness?



  • We had the same issue on kernel 14.16.6. Reverting back to 4.15.2 fixed this for us as well.



  • @tom-elliott We are seeing the same thing. Went from 1.5.2 to 1.5.3. Switching to the 4.15.2 kernel fixed this problem for us.

    Thanks



  • Okay thanks we will try that, we are just starting to use FOG so a fresh install isn’t a big problem for us


  • Senior Developer

    The best I can suggest is maybe try an older kernel for now. Jumping between versions is a bit extreme. I believe 1.5.2 was on 4.15.2 kernel


 

512
Online

5.4k
Users

12.6k
Topics

118.7k
Posts