Try to use other language


  • Developer

    Hi,
    I try to select other language that is not english, for example, spanish or german, but the web UI appears only in english. Is a bug or maybe the browser configuration? or is a DT’s super filter in inet (America first) XDDD?


  • Developer

    OK. I will create the files for Basque.

    I will update the Spanish files too ;)


  • Senior Developer

    @fernando-gietz you also built the appropriate mo file in the eu_ES.UTF-8/LC_MESSAGES/messages.mo?

    Of course you’d need the translation po file in place to build the mo.

    It should work as long as you have locale generated and available on the system too.


  • Developer

    Hi Tom,

    thanks for the info.

    I have make the changes and now appears me the Euskal entry in the list box, but when I try to change the language from Spanish to Euskal, the WEBUI appears in Spanish :(

    I cleared the history and clean the browser cache


  • Senior Developer

    I’ve added Basque to the translations list for 1.6. It’s a bunch of work to add if you’re trying to do it manually. You need:

    Edit /var/www/fog/commons/text.php and add the line:

    $foglang['Language']['eu'] = 'Euskal';
    

    Edit /var/www/fog/lib/fog/processlogin.class.php and look for: 'es

    After the relevant found item you’ll add the case/if statements for it using 'eu_ES as the translation code.

    Add the relavent /var/www/fog/management/languages/eu_ES.UTF-8 folder(s) and files. The structure looks like:

    /var/www/fog/management/languages/eu_ES.UTF-8
    /var/www/fog/management/languages/eu_ES.UTF_8/gpl-3.0.txt
    /var/www/fog/management/languages/eu_ES.UTF_8/LC_MESSAGES
    /var/www/fog/management/languages/eu_ES.UTF_8/LC_MESSAGES/messages.po
    

    Hopefully that helps.


  • Developer

    We have two official languages in my university: Spanish and Basque (Euskera), I can set the default language the spainish language but if somebody wants the basque, actually he can not set it.


  • Senior Developer

    Maybe I can get your help in fixing this? I know you’re asking about it, I can tell you what I think it’s related to.

    I believe it’s due to how session_start is occurring. During initial login a session is started, once logged in a another session is created using the new login information. It’s this reset of the session I believe is causing the problem.

    Also, I believe you may need to ensure you have the locale installed on the base system too. I’ve tested this a few times and didn’t see anythign particularly troubling, but then again I only tested at a very basic level.


  • Developer

    I have found in FOG Settings -> General Settings an entry:
    DEFAULT LOCALE = Español

    With this setting I can see the web UI in spanish but I can not change to other language .


Log in to reply
 

494
Online

6.2k
Users

13.6k
Topics

128.0k
Posts