PXE Boots one one desktop but not another



  • Fresh install, the second time I’v had to do this, of Ubuntu 11.04 and current FOG.
    After the install I took my master image computer and successfully booted into PXE, completed host registration and inventory, assigned a task to upload the image, all good.

    Then when trying to deploy the image to a brand new HP desktop of same make model etc I can not get it to PXE boot. Here is what I have noticed that may be an issue. The IP address of the FOG server, DNS, DHCP etc all are 192.168.10.* but the company does also deply 192.168.12.* addresses.

    The failing desktop DOES have a 192.168.12.* address. I’ve changed it to a static IP address of 10.192.168.** but even then it will not boot into PXE. I have manually registered the desktop into FOG and it does not resolve.

    One thing that I did during the FOG setup is to set the Subnet/netmask to 255.255.255.0 maybe it should be 255.255.0.0 to be able to resolve those machines with the .12 address? If so I can’t figure out how to change it in the FOG configuration.

    Any help, please give specific instructions, would be greatly appreciated.

    Erin


  • Moderator

    If one machine still boots to PXE and run something like a hardware inventory, then I wouldn’t think it is the TFTP password. Schedule a hardware inventory task for a machine in the 192.168.10.x network and make sure that works.

    If that works. Try to schedule a task for a machine in the 192.168.12.x network. Schedule it through the web interface, then check the /tftpboot/pxelinux.cfg/ folder for a task file matching your machine (01-mac-address-of-machine). If you get a file in that folder, paste the contents into this thread (use code tags).



  • Sounds like it might be a password issue for tftp. I think. Maybe.

    Reference this: http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP

    Particularly the bit about setting the password for the user “Fog” and it matching [B]TFTP_FTP_PASSWORD[/B] and [B]STORAGE_FTP_PASSWORD [/B]in /var/www/fog/commons/config.php (at least that’s my path in 11.10)

    Seems like I had something else to do as well, but I guess start with that and see how it goes.



  • Another interesting little tidbit. In FOG when I got to Other Information and attempt to set a master password an error message appears
    "PXE menu update failed. Unable to connect to tftp server"

    FYI - I received this message yesterday and did stop and restart the tftp server via Terminal by typing in sudo stop tftpd-hpa and sudo start tftpd-hpa



  • Hello Chad,
    There is no file except Default in /tftpboot/pxelinux.cfg/
    What other information can I provide?


  • Moderator

    Do you have a file on the FOG Server in /tftpboot/pxelinux.cfg/01-Mac-address? If so, can you paste the contents?



  • That was awesome! Now the .12 machines are able to get to the FOG menu but there is still ONE issue. I was able to register the host but imaging failed.
    "Unable to connect to tftp server"
    is the error now.

    Almost there :-)


  • Moderator

    Check the config on the DHCP server. Maybe the scope definition for 192.168.12.x has a syntax error for the filename option.



  • No, I don’t even get the FOG menu. It errors out trying to find pxelinux. I believe the error is No Image File Found.


  • Moderator

    On the 192.168.12.x network, do you even get the FOG menu or does it error out trying to find pxelinux.0?



  • The gateway for those which will not PXE boot is a .12 address of course and .10 for the ones that will PXE boot.



  • The same DHCP server supports both. I verified that one right off :-)
    Thanks for helping Chad. I really need it!


  • Moderator

    Does the same DHCP server support both 192.168.10.x and 192.168.12.x or do they have separate DHCP servers?



  • Yes, that is the exact scenario.


  • Moderator

    So clients in the subnet 192.168.10.x can pxeboot and get the fog menu but clients in the 192.168.12.x subnet cannot. Is that the scenario?



  • The silence is deafening.



  • Hello Chad,
    Yes I do have a DHCP server which (if it matters) does have a 192.168.10.* address. There is no problem whatsoever accessing network resources, etc just can get machines with this 192.168.12.* address to PXE boot. Image file not found. So I am assuming that something else needs to be set on my FOG server.


  • Moderator

    Do you have a DHCP server for your computers or are they all set static?


Log in to reply
 

485
Online

38916
Users

10687
Topics

101371
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.