FOG 1.5.2 Image Capture Lags



  • FOG Server Version 1.5.2
    FOG Server: Debian 9.4

    Hi all,

    It’s that time of year again! Summer season is about here in our district and I’m getting ready to image for the season. I recently updated to FOG ver 1.5.2. I have noticed that the basic image capture task (partclone) seems slower and with lag, in comparison to older versions.

    I have had two image capture tasks that lag to the point of no return. I had one yesterday that was stuck on the same spot for 2 hours, after I discovered it hadn’t finished. I finally killed the task and restarted the session. Things picked back up and captured like normal.

    These tasks have all been when I have been imaging Windows 10 images from a Hyper-V VM.

    Let me know if their are any log files you’d like and I’ll post.

    Thanks for everything!

    Cheers,

    Joe



  • @quazz

    So I tried re-capturing the image from my VM and it finally finished but took forever. I left a ping running on the host and the server and never had any lost packets. I had some higher ping times going to the VM were average with one very high number. But never any packet loss.

    I decided to try and capture the image to a brand new image and not one I had used previously. I noticed my transfer rate was higher and it ultimately finished capturing the image.

    Could the delay simply be the difference between imaging a Windows 10 machine versus a Windows 7 Machine? This is the first image I have created of a Windows 10 machine.

    Let me know if you have any thoughts on this.

    Thanks again for making me think more about it. :-)

    Cheers!


  • Moderator

    @joe-gill The rate is just calculated based on the amount of data sent divided by the time spent sending it. Given that it doesn’t continue at a certain point we’d expect the rate to drop indefinitely.



  • @quazz

    Another interesting observation is that Deploying existing images seems to go fast without issue. It’s just when I try to capture new images. I will test a capture from a different device and see what happens.



  • @quazz
    The funny thing is that they are both hosted on the same VM… I don’t know what is going on. I tried rebooting my FOG server and the Windows 10 VM I"m trying to image and it’s still not getting anywhere. I noticed that the Rate went as low as 50 megs… Normally my rates are up over a gig / min.

    I’ll dig deeper from the network perspective and see what happens. It’s bizarre.

    Thank you for your advice!


  • Moderator

    At a guess, I would say it loses connection with the FOG server at some point.



  • One more observation…

    On the host…

    Every time this happens, the Elapsed Time, Remaining Time and Rate are running. The Current Block never changes nor does the Total Block.

    The host is configured with a legacy network card (VM)…

    Cheers!


Log in to reply
 

335
Online

6.4k
Users

13.8k
Topics

130.3k
Posts