Problem PXE boot since windows 10 1803

  • Hello,

    I’m testing deploiment of 1803 version of windows 10.
    And, on my Dell optiplex 7440 et 9030, who worked perflectly with 1607 and 1709 version of windows 10, I have now a blink cursor on reboot.

    I don’t have this problem exiting PXE.
    I don’t have this problem on a qemu VM.


  • This morning, I have the problem on several machines which have get 1803 update…
    I have changed the dhcp configuration for this machine to point to my testing fog server. (1.5.2)
    On this server, I have applied Quazz solution to set grub in place of sanboot and now my Dell machines on 1803 have started passing by PXE…

    Now I have to set it to my production fog server…

    Thanks for your help

  • @lebrun78
    You could try seeing with file it is PXE booting with by deploying it and then on your FOG Server do a tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011. You may have to adjust which file it locates to in your dhcp config file.

  • Moderator

    @lebrun78 You could try a different disk boot command. You can choose these globally, per group or per host I believe. Default is Sanboot if I’m not mistaken.

    There’s different options because different hardware handles it differrently, annoyingly enough.

  • I have this problem only with recent Dell hardware.
    May be I can change au bios paramete, but which one ?


  • May be I am not clear.
    All my compututer are boot first on pxe controlled by FOG.
    But I have no problem with computer that are running Linux and Windows10 =< 1709.
    But for computer that are running Windows 10 1803, available for 2 weeks, boot chainon between pxe and harddrive doesn’t work.
    To start this machine I have to disable bios or escape oduring PXE loading.

  • Developer

    @lebrun78 What machine do you see this issue on? Is this after cloning to a client on booting (chainload from disk) or is it your master machine that you just upgraded to 1803 which shows this problem when chainloading from disk? I am just trying to get the full picture.

    I don’t have this problem on a qemu VM.

    So you are saying you have upgraded a qemu VM to 1803 as well and that one does chainload properly? I’d guess this is a sign that disk (controller) drivers might play a role here. Since 1803 had it’s history (it’s May not, hey!) I am not sure how many people have looked into trying at much yet.

  • I use fog 1.4.4 on centos 6.8.
    I use non-resizable image but the problem seem to be on boot chaining between ipxe and windows.

  • Developer

    @lebrun78 What version of FOG are you running right now? Is this a resizable or non-resizable image?

Log in to reply