iPXE Menu item disappears from boot menu



  • I have created a new iPXE Menu item for doing an unattended Debian 9.4 installation using a preseed file. Everything works well and as expected. When debugging the new menu item I was watching the iPXE boot menu for changes (i.e., http://192.168.0.xyz/fog/service/ipxe/boot.php), and just happened to notice that my new menu item would sometimes disappear from the iPXE boot menu. The client then would not have a chance to select it. Long story short, I finally realized that after switching the “Menu Show with” from “All Hosts” to “Registered Hosts” and refreshing the iPXE boot menu, that it would disappear from the menu. Only after switching it back to “All Hosts” did it reappear. I also never lost the actual text in the menu.
    This is a reproducible bug and I would assume not by design. I am using FOG 1.5.2 Server on a CentOS 7.x install. Please let me know if you need any other information.



  • @tom-elliott Tom, I just got around to installing a fresh CentOS 7.5 minimal server with FOG 1.5.4. I used the wiki instructions to install this system to the letter and it appears to be fixed. Sorry for the delay. I have another issue with 1.5.4 which I will detsil in a separate post. Thanks for your help and this post is indeed solved.


  • Senior Developer

    Solving this thread as this should be fixed and we haven’t heard back. Feel free to open this or start a new thread linking back to here if this problem is still happening.


  • Senior Developer

    Bump, any update on this?


  • Senior Developer

    @foguser438 have you tried installing the working branch to see if it fixed the issues as you’ve described? Essentially the menu would fail to display but the function would be present. The item would not display because it was missing a description. I’ve fixed this in the working branch and believe it will fix the issues as you’ve described. That said I am working on a different version of fog and am kind of tied up with those changes over the 1.5 series at the moment. Normally I have no problem testing and finding the fix, I just can’t at the moment.



  • @Tom-Elliott , please let me know if you were not able to re-create the disappearing iPXE Menu using the example provided in the previous post.


  • Senior Developer

    @foguser438 the description is a known problem and is fixed already for when it 1.5.3 comes out. Description, in the past, was also required though that was unintentional and has also been addressed in the working branch (will become 1.5.3)



  • Hi Tom, yes the host is registered. However, the fact that it disappears from the boot menu PHP code on the server seems to be the problem here. It would not even present the menu to the registered host in the first place. There is also the small problem of why the Description fails to carry over to the new menu item once created with one.


  • Senior Developer

    @foguser438 is the host your seeing it disappear from a registered host? If not this would be why the machine doesn’t have the menu item when “Registered Hosts” is the selected item



  • Hi, as mentioned this is reproducible so you don’t need my exact example. To show this problem, simply do the following:

    1. Connect to your FOG 1.5.2 UI.
    2. Open a second tab on the browser to the iPXE boot page:
      http://192.168.0.xyz/fog/service/ipxe/boot.php
    3. In the FOG UI go to FOG Configuration->iPXE New Menu Entry
    4. Create a basic boot menu entry using:
      Menu item: fog.test
      Description: Test boot entry
      Parameters: GOTO MENU
      Menu Show with: leave it as default (Not Registered Hosts)
      Click Save Changes
    5. Refresh iPXE boot menu in second tab. fog.test shows as expected.
      NOTE: the description fails to carry over to the boot menu and must be re-added later in the Edit menu.
    6. Now go to FOG Configuration->iPXE Menu Item Settings and select fog.test.
    7. Change the “Not Registered Hosts” to “Registered Hosts”.
      NOTE: You must also add the description: Test boot entry back in as it has not carried over from the initial create.
    8. Refresh the iPXE boot menu in the second tab and notice that the boot entry for fog.test disappears. This also is reflected to the client as the entry cannot be selected.
    9. Finally, go to FOG Configuration->iPXE Menu Item Settings and select fog.test…
    10. Change the “Registered Hosts” to “All Hosts” and refresh second tab once again. The fog.test entry reappears and is once again available to the client.

    For completeness, I have attached the three screen shots showing the test menu item using all three settings; however, they are nothing special to this issue.

    Screenshot of fog.test creation:
    0_1525546873993_fog.test default new not registered.png

    Screenshot of fog.test change to Registered Hosts:
    0_1525546912726_fog.test registered hosts.png

    Screnshot of fog.test change to All Hosts:
    0_1525546944614_fog.test all hosts.png

    HTH


  • Moderator

    Please post a screen shot of how you have the menu configured in the fog gui. The fog ipxe menu should be consistent every time.


 

609
Online

5.4k
Users

12.6k
Topics

118.8k
Posts