Installing on Ubuntu 18.04



  • Hi All,

    I’ve just tried installing Fog on Ubuntu 18.04 by following the directions:

    tar -xzvf fogproject-1.5.2.tar.gz
    cd fogproject-1.5.2/bin
    sudo ./install.sh
    

    Ubuntu reports that there is no such file or directory. Am I missing something?

    Matt.



  • @Boyan-Biandov yes, but I prefer to use the working branch because it uses Ubuntu’s PHP7.2, which makes it more compatible with other software.



  • Hi everyone,

    So to put this discussion to rest do we all agree that the current version of FOG 1.5.4 (master branch, tarball, latest stable and production release) fogproject-1.5.4.tar.gz installs just fine on Ubuntu 18.04.1 LTS server?

    Thank you
    Boyan



  • @danuel That’s neat. And appreciated. But, Ubuntu 18 is installing out-of-box for me for 37 days straight now (see my signature).



  • hello all!!
    I am out for long time! :)

    Well I think what is problem here. Ubuntu 18 does not come with some repositories on sources.list :)

    I Resolve my problem for intalling fog on ubuntu 18 on that way! Running that: (If you run in root user, remove sudo, of course :P )

    sudo echo "deb http://cz.archive.ubuntu.com/ubuntu bionic main universe" >> /etc/apt/sources.list
    sudo apt-get update
    

    Now your FOG Installation it’s able to download all packages and install :)

    Best Regards! I hope this helps!



  • Hi there, we have trouble installing Fog on Ubuntu 18.04.1, see
    https://github.com/FOGProject/fogproject/issues/258
    Do you have an estimate when Ubuntu 18 will be supported out of the box?



  • @nt_tech I would recommend Debian 9. I have a number of reasons for this.



  • @tom-elliott Tom, I am open to any distro. While I have always used Ubuntu with FOG, I would like to know what you are programming and testing on, so I can use the same distro. Just makes sense since I am building a new server anyway.

    So…what are you using?

    Brian


  • Senior Developer

    @coconutdog what this is telling me is the installer can’t detect your nic, which is why it’s stuck in a loop for you. I will try relatively soon to get 18.04 support added, but I feel all should understand this is a common thing with Ubuntu releases. Even with Fedora I tend to have less compatibility issues. As @Joe-Schmitt stated, Ubuntu likes to deviate from other distros in their approach on many things.

    For example, for some reason your network interface is not being detected automatically. We already have two checks and neither of them are returning the interface. Also, installing curl is not possible because it’s looking for libcurl first. That seems like a problem for the package manager to resolve, but I’ll have to figure out a way to do it on my own.


  • Senior Developer

    @Coconutdog I would recommend switching to an earlier LTS, or a different distribution such as Debian or CentOS if you need to get your FOG server working as soon as possible. Ubuntu 18.04 was released only a few days ago, and there are likely multiple things they changed that will break FOG until we can identify and patch them. With that said, if you are still interested in using Ubuntu 18.04, then we’ll definitely help patch your issue and any other 18.04 issues you encounter.

    In general, new Ubuntu releases actually tend to be the least compatible with FOG compared to most other distributions, as they derivative from certain conventions and take their own approach on things.



  • Hi Fellas,

    I was using the instructions on the download page.
    Using:

    ./installfog.sh
    

    worked.

    It seemed to stall on the network interface choice if one selects no as an answer:

    Would you like to change the default network interface from ?
      If you are not sure, select No. [y/N] n
    
      Would you like to change the default network interface from ?
      If you are not sure, select No. [y/N] N
    
      Would you like to change the default network interface from ?
      If you are not sure, select No. [y/N] y
      What network interface would you like to use? 
    
      Would you like to change the default network interface from ?
      If you are not sure, select No. [y/N] n
    
      Would you like to change the default network interface from ?
      If you are not sure, select No. [y/N] y
      What network interface would you like to use? enp7s0
    

    It seems you have to select yes and then supply an interface name.
    Thank you all for your help so far, I’ll get there eventually.

    Matt.



  • @coconutdog The install script needs to be run from the installation directory.

    Make sure you cd to the dir with the install script before running.


  • Senior Developer

    @Coconutdog it would appear the instructions on our download page were incorrect (as pointed out by Tom). I’ve updated the page with the correct instructions.


  • Senior Developer

    @coconutdog which directions did you follow? I ask so we can fix them then. The install.sh should be installfog.sh


 

475
Online

5.4k
Users

12.6k
Topics

118.7k
Posts