Fog Client problem xubuntu



  • Hello (I don’t speak english, but I tried to write à little message).

    I have installed fog 1.5.2 git (stable). For xubuntu client. (old computers).

    I’ve imaging well, but fog clie,t don’t work. Thank’s for suggestions

    I read that : 0_1524819369922_fog.log


    --------------------------------Authentication--------------------------------

    26/04/2018 23:52 Client-Info Version: 0.11.12
    26/04/2018 23:52 Client-Info OS: Linux
    26/04/2018 23:52 Middleware::Authentication Waiting for authentication timeout to pass
    26/04/2018 23:52 Middleware::Communication Download: http://192.168.224.30/fog/management/other/ssl/srvpublic.crt
    26/04/2018 23:52 Middleware::Authentication ERROR: Could not authenticate
    26/04/2018 23:52 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority


    --------------------------------Authentication--------------------------------

    26/04/2018 23:52 Client-Info Version: 0.11.12
    26/04/2018 23:52 Client-Info OS: Linux
    26/04/2018 23:52 Middleware::Authentication Waiting for authentication timeout to pass
    26/04/2018 23:54 Controller Stop
    26/04/2018 23:54 Service Stop requested
    26/04/2018 23:54 Middleware::Authentication ERROR: Could not authenticate
    26/04/2018 23:54 Middleware::Authentication ERROR:
    26/04/2018 23:54 Bus Emmiting message on channel: Status
    27/04/2018 09:17 Main Overriding exception handling
    27/04/2018 09:17 Main Bootstrapping Zazzles
    27/04/2018 09:17 Controller Initialize
    27/04/2018 09:17 Controller Start

    27/04/2018 09:17 Service Starting service
    27/04/2018 09:17 Bus Became bus server
    27/04/2018 09:17 Bus Emmiting message on channel: Status
    27/04/2018 09:17 Service Invoking early JIT compilation on needed binaries


  • Developer

    @jpLeca Could you please send your last answer in your native language as well. Might help us all understand a bit more and could be helpful to other users too.



  • I n succeeded has to run the customer.
    But I needed it mainly to rename customer after image.
    I succeeded has to do it with script comment configuration of fog.



  • Thank for the reply.
    I’ve try the suggest of tom.
    Uninstall ok, etc.
    But when computer reboot i’ve the same problem (not in first install, i’ve looking fog.log.)
    I’ll be try the joe suggest, but i don’t know how install an old mono :(


  • Senior Developer


  • Senior Developer

    @jpLeca this issue is caused by newer versions of mono having a broken keystore. I hope to circumvent this issue in the future but in the mean time:

    Try uninstalling the client, removing mono and installing an older build, and then installing the client . Note that may have to repeat these steps until you find a mono build that does not have the bug.


 

481
Online

41.8k
Users

12.4k
Topics

116.6k
Posts