• Hello everyone,

    I tried to set up GParted Liveboot from this guide:
    https://forums.fogproject.org/topic/8301/gparted-setting-for-fog-1-3-0-rc7-tested-working

    but when i start to select the item there comes this kind of error:

    alt text

    I saw that the IP was missing so i tried to change the configuration a bit.
    to this:

    kernel http://192.168.1.128/iso/gparted/live/vmlinuz vmlinuz boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=${192.168.1.128}/iso/gparted/live/filesystem.squashfs
    initrd http://192.168.1.128/iso/gparted/live/initrd.img
    boot

    alt text

    when i saved the configuration and boot up a test machine, after selecting GPartet as bootoption the screen turns black and nothing big happens.

    Please tell me where i went wrong.

    Thans User.

  • Senior Developer

    @b_man said in GParted Live from FOG:

    Out of curiosity, how come this was marked as solved?

    Not sure if you noticed but this is an old topic that was marked solved even before you posted. That’s one of the reasons why we keep telling people to open their very own topics and post all their details in that new one. Makes things a lot clearer. If you think a lot of the information is in the old topic, then just link to it from your new one.

    Please add details like the exact commands used to prepare the files and version of GParted you use as this might make a difference. As well post if you boot in UEFI or legacy BIOS mode and if it’s a VM setup or on hardware.


  • Out of curiosity, how come this was marked as solved? Still cannot boot into GPARTED. Is there something wrong with my tftp settings? Any other methods?


  • @george1421 I set the computer to boot to Legacy and also updated the FOG parameter settings to what you posted.

    As far as the Kernel goes, running file /tftpboot/iso/gparted/live/vmlinuz returned:

    /tftpboot/iso/gparted/live/vmlinuz: Linux kernel x86 boot executable bzImage, version 5.10.0-6-686 (debian-kernel@lists.debian.org) #1 SMP Debian 5.10.28-1 (2021-04-09), RO-rootFS, swap_dev 0x4, Normal VGA

    It still will not boot to Gparted. Can you post instructions on how to properly download and
    extract the iso to that folder? Maybe I did not do that correctly.

    Here are my menu parameters:

    8403df6e-6da7-402f-a949-2d182f515021-image.png

    Here is part of my ISO files:

    [root@localhost ~]# sudo tree -d /tftpboot/iso/gparted/
    /tftpboot/iso/gparted/
    ├── boot
    │   └── grub
    │   ├── i386-efi
    │   └── x86_64-efi
    ├── [BOOT]
    ├── EFI
    │   └── boot
    ├── live
    ├── syslinux
    └── utils
    ├── linux
    │   ├── x64
    │   └── x86
    ├── mbr
    ├── win32
    └── win64

    16 directories
    [root@localhost ~]# sudo tree /tftpboot/iso/gparted/live
    /tftpboot/iso/gparted/live
    ├── filesystem.packages
    ├── filesystem.packages-remove
    ├── filesystem.squashfs
    ├── GParted-Live-Version
    ├── initrd.img
    ├── memtest
    └── vmlinuz

  • Moderator

    @sebastian-roth said in GParted Live from FOG:

    By the way, do you think the double … vmlinuz vmlinuz … in that line is correct? I don’t think it’s causing an issue but nevertheless stumbled upon this.

    Well that format is understood but still a little confusing to read. If you rewrite the call so its a bit clearer it would look like this

    kernel tftp://${fog-ip}/iso/gparted/live/vmlinuz 
    initrd tftp://${fog-ip}/iso/gparted/live/initrd.img
    imgargs vmlinuz boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/iso/gparted/live/filesystem.squashfs
    boot
    

    In regards to the OP’s error. One might think that secure boot is turned on or you are trying to boot a bois or uefi boot image with the opposite firmware.

    What I might do is on the fog server and run file /tftpboot/iso/gparted/live/vmlinuz to see if it comes back as a valid linux kernel.


  • @sebastian-roth Yes, that is where the iso was extracted to.

  • Senior Developer

    @b_man said in GParted Live from FOG:

    kernel tftp://${fog-ip}/iso/gparted/live/vmlinuz vmlinuz boot=live ...

    Do you have the ISO file extracted to /tftpboot/iso/gparted/ on your FOG server?

    @george1421 By the way, do you think the double ... vmlinuz vmlinuz ... in that line is correct? I don’t think it’s causing an issue but nevertheless stumbled upon this.


  • @george1421 I setup everything as instructed, but I still have an error. My extracted iso is at /tftpboot/iso/gparted.

    My menu config file parameters are

    kernel tftp://${fog-ip}/iso/gparted/live/vmlinuz vmlinuz boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/iso/gparted/live/filesystem.squashfs
    initrd tftp://${fog-ip}/iso/gparted/live/initrd.img
    boot

    What might I be doing wrong?

    OS: CentOS 8

    Error: Operation not supported could not boot (http://ipxe.org/3c126003)

    863d6de2-4724-43d5-bf57-784cbec9dbbf-image.png


  • ah great, i didnt now that when i use TFTP i habve to change the directory.
    a big thanks for your help 🙂
    it boots up and i get another Error, but i think i have to create another tread for this problem

    it stops there:
    alt text

    greedings User

  • Moderator

    With the http redirection that fog is currently using, its a bit difficult to host other files under the http protocol.

    So what can you do?

    Move to one of the other supported protocols like tftp:// or nfs://

    To use the tftp:// protocol you would update your menu to be something like this (note I fixed your fetch kernel parameter too).

    kernel tftp://${fog-ip}/iso/gparted/live/vmlinuz vmlinuz boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=tftp://${fog-ip}/iso/gparted/live/filesystem.squashfs
    initrd tftp://${fog-ip}/iso/gparted/live/initrd.img
    

    The only thing I’m unsure of is if the kernel supports tftp pulling. Also the variable ${fog-ip} is replaced by the fog menu with the IP address of your fog server. Hard coding the IP address in the fog menu doesn’t make it very portable.

    So since we are using tftp:// protocol you need to place the files in /tftpboot/iso/gparted based directory.

    If that doesn’t work then you could try nfs:// which should be supported by the linux kernel.

327
Online

8.4k
Users

15.2k
Topics

142.5k
Posts