UEFI - No fog menu



  • Hi,

    I have a fog server on debian stretch, fog version is 1.4.4 for production (I try the same in the last 1.5.2 for test).
    I setup a Optiplex 3010 to boot on UEFI, but I have no menu.

    In my log file I have: "RRQ from 192.168.0.246 filename ipxe.efi"
    On the computer, I have:

    Succeed to download NBP
    iPXE initialising devices...
    

    so it’s look than the file is downloaded but nothing else.
    Actualy I don’t make any custom things to setup UEFI boot on my Fog.

    Any idear ?

    Regards



  • @Quazz True, but I wan’t to see what can be done with UEFI. In the future I will make almost all my deployment by UEFI boot. So I hop it will work find, I see than UEFI is not standardize as Legacy. So it was to understand.


  • Moderator

    @totoro A quick search on the forum indicates that this model has been fickle for years.

    Does PXE boot in Legacy work? (you can deploy UEFI images in Legacy, then boot hard drive in UEFI as a possible solution)



  • @george1421 Same problem, no change.


  • Moderator

    @totoro For the next test, please download this ipxe.efi file from my google drive. This file is from 1.4.4. I’m interested in seeing if the older version of iPXE works as intended. https://drive.google.com/open?id=1RlJJ5JhVFW9noG_tn83ive4aOiEAM1QS



  • Hi,

    Yes that correct, I juste update the bios today and try. For the number 5, the 3010 reboot alone after few minute on “Initializing devices…”.

    I have no problem with a debian uefi boot, it’s fast and working. But I have no fog tools :’(


  • Moderator

    @totoro Just so I know where you are at in the testing.

    1. You are using fog 1.4.4
    2. You are trying to pxe boot into uefi on 3010
    3. You have secure boot disabled on the 3010
    4. You are pxe booting ipxe.efi
    5. The 3010 stops at “Initializing devices…”

    Is that correct?

    Have you confirmed that your 3010 has an updated firmware to the latest (at least latest as of Dec 2017)?



  • Hi thank’s for your answer.

    So I try with ipxe.efi, with two different computer (HP Prodesk 400 G3 and Dell Optiplex 3010) at start I was trying only with the Dell.
    I disable secure boot on both.
    It’s working on the HP (so thank’s) but on the Dell it’s making the same problem at the start, with a reboot after few minuts.

    Any idear for the Dell ?

    I try with a Debian howto (https://wiki.debian-fr.xyz/PXE_avec_support_EFI#AVG_Rescue_CD_GNU.2FLinux) and it’s working on both


  • Moderator

    Back with your original configuration using ipxe.efi. Did you remember to disable secure boot on that uefi system? If secure boot is on (setting in the firmware bios) then I have see ipxe initializing devices… will stay on the screen or the target computer will just reboot.

    Just a word of warning, with the newer versions of FOG, intel7156.efi and all of the xxx7156.efi boot loaders are removed since the iPXE Project has updated iPXE to support these specific models.

    The last question, what hardware (manufacturer and model) are you trying to pxe boot?



  • Hi thank’s for the answer.
    I use the intel7156.efi one, i will try a other to see.
    But now I see the iPXE boot, but new message:

    DHCP Failed, hit 's' for the iPXE shell; reboot in 10 seconds
    

    Any new idear ?



  • @totoro Try different .efi files until you find one that works. They are all in /tftpboot in one spot or another.


 

495
Online

41.8k
Users

12.3k
Topics

116.1k
Posts