PXE boot but no DHCP offers (with interface eth1)



  • I have a new fog install (1.5.1 on Ubuntu 16.04). It is running standalone (DHCP, PXE integrated) on a simple LAN with a single Dell Powerconnect 5448 switch. I have portfast enabled on all the ports.

    I am using a Dell 780 for a test client. It will PXE boot but once I make a menu selection (Full Inventory etc) it comes back with an error it is not getting any DHCP offers.

    However when I boot the same machine into windows it is picking up the dhcp information correctly.

    I did have to correct some things on the server due to the way the newer distro’s assign interface names i.e. Names incorporating Firmware/BIOS provided index numbers for on-board devices (example: eno1) rather than eth1

    I did notice the PXE message mentioned it was trying to address eth1. Could that be the issue and where do I need to change the PXE config to correct it if so?

    Thanks for the attention to this matter,
    GP


  • Moderator

    There are a few things here.

    1. Upgrade to 1.5.2 because it addresses a few issues.
    2. The 780s did have an issue with pxe booting and picking up an IP address. I don’t feel that is the issue here, but just be aware.
    3. Can you post a clean picture of the actual error so we can see the context of the error?
    4. When pxe booting happens and then we see random issues with dhcp, that is typically related to having a network switch with spanning tree enabled (a good thing), but the switch is not using one of the fast spanning tree protocols (not such a good thing). As Wayne said, put an unmanaged (dumb) switch between the building switch and the pxe booting computer. If the computer boots and runs through FOG OK, then your building switch does have STP enabled instead of RSTP or what ever your switch vendor calls it.


  • @gporter Put a dumb-switch (an unmanaged switch) between the target host and the network and see how that goes.


 

533
Online

5.4k
Users

12.6k
Topics

118.6k
Posts