hosts registration



  • Hi all !
    I have a problem with fog with some computers that i can’t see in the console in pending hosts.

    I install a new server in a debian and with FOG_1.5.0, i want to use FOG for snapins so, i install (manually) the FOG Client in some computers.

    Next i go in my web interface and see only a few hosts in “Host Management”…
    If i look in c:\fog.log i see that log :

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     14/03/2018 11:28 Client-Info Version: 0.11.15
     14/03/2018 11:28 Client-Info OS:      Windows
     14/03/2018 11:28 Middleware::Authentication Waiting for authentication timeout to pass
     14/03/2018 11:30 Middleware::Communication Download: http://srv-fog1-n0/fog/management/other/ssl/srvpublic.crt
     14/03/2018 11:30 Data::RSA FOG Server CA cert found
     14/03/2018 11:30 Middleware::Authentication Cert OK
     14/03/2018 11:30 Middleware::Authentication No token found at C:\Program Files (x86)\FOG\token.dat, this is expected if the client has not authenticated before
     14/03/2018 11:30 Middleware::Authentication ERROR: Could not get security token
     14/03/2018 11:30 Middleware::Authentication ERROR: Le fichier 'C:\Program Files (x86)\FOG\token.dat' est introuvable.
     14/03/2018 11:30 Middleware::Communication POST URL: http://srv-fog1-n0/fog/management/index.php?sub=requestClientInfo&authorize&newService
     14/03/2018 11:30 Middleware::Response Invalid security token
    
    
     14/03/2018 11:30 Middleware::Communication URL: http://srv-fog1-n0/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     14/03/2018 11:30 Middleware::Response Success
     14/03/2018 11:30 Middleware::Communication URL: http://srv-fog1-n0/fog/management/index.php?sub=requestClientInfo&mac=00:09:0F:AA:00:01|DC:4A:3E:7C:78:DD|00:09:0F:FE:00:01&newService&json
     14/03/2018 11:30 Middleware::Authentication Waiting for authentication timeout to pass
    
    

    I try to reboot the host many time, i reboot the apache2, i reboot the server… but i’m lost ! :(

    Do you have any idea of what appen ?

    Thanks !



  • Ok thanks.


  • Senior Developer

    @laurentb go in GUI, click hosts, find the host saying this, click on it to edit. At top of page you should see a big orange button saying “reset encryption data”



  • @Tom-Elliott no i dont’ because i dont’ know how…:)
    (but if you coul’d explain it to me i will keep the info if i have the case another time).


  • Senior Developer

    I’m just going on a limb but the log message you provided says “Invalid Security Token”. I’m going to guess you already performed the “reset encryption data” for them?



  • Note for admins… i want to mark the topic as “Solved” but i don’t see the option…



  • @Wayne-Workman and @Joe-Schmitt thanks a lot for your help guys but it works now !!!
    i finaly found what’s wrong… !!! :D

    @Joe-Schmitt yes the computer isn’t showing up under all hosts AND pending.

    For your information, i try to install a previous version of FOG (1.4.4) and i use a couple of computers for my tests.

    After this i install “the real” server with the lastest version 1.5.0
    After that i try to delete and install the FOG client with the sames computers AND some others.
    Like i said some of them don’t works…

    SO, with the computers that were not working I totally uninstall FOG CLIENT, I purge the registry, i reboot…
    AND i make a new clean installation and it works !!!

    At the end i think there was a bad key left in the registry despite the “classic” uninstall.

    Thanks again.


  • Senior Developer

    @LaurentB Is that client log from a computer which isn’t showing up under all hosts AND pending?

    • @Wayne-Workman there’s no indication that this is a database issue yet, so it’d be best to avoid running destructive SQL commands until we know more.


  • @laurentb I’m not sure what’s wrong. I suggest you run the database maintenance commands in this link to see if that resolves the problem. Also preemptively asking @joe-schmitt to look at this thread.



  • @Wayne-Workman For those whom I see yes but the problem is that some host are not visible at all



  • @laurentb Did you accept the pending hosts?


 

342
Online

41.2k
Users

11.6k
Topics

110.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.