Inventory - Case Asset, HDD Information not being populated



  • Fog Version: 1.5.0 RC 12

    Case Asset Tag:
    I had the client machine re-run the inventory task and as I was watching, the field for Case Asset Number was blank.

    Reviewing the FOS funcs.sh script I saw that the doInventory function assigns the chassis-asset-tag using this:

    casesasset=$(dmidecode -s chassis-asset-tag)
    

    However, in fog.inventory the following is used to display the case asset tag:

    dots "Case Asset Number:"
    echo "$caseasset"
    

    Changing the echo statement to use $casesasset while in FOS Debug mode, fixes the echo that occurs during the inventory task.

    The case asset tag, however, is still not being recorded in the database. I think there is just a variable mismatch where some code is using ‘caseasset’ and other code is using ‘casesasset’. I have not been able to confirm this yet.

    Hard Disk Model, Firmware and Serial Number:
    I think there is a compatibility issue with NVMe drives. I have looked at a couple of different clients and it seems that only the machines that have NVMe drives is impacted. Here is the output I gathered on a Dell Optiplex 5050 with a M.2 256GB PCIe Class 40 SSD for FOS Debug.

    # lsblk -dpno KNAME -I 3,8,9,179,202,253,259 | uniq | sort -V
    /dev/nvme0n1
    
    # hdparm -i /dev/nvme0n1 
    /dev/nvme0n1:
     HDIO_DRIVE_CMD(identify) failed: Inappropriate ioctl for device
     HDIO_GET_IDENTITY failed: Inappropriate ioctl for device
    

  • Developer

    @jburleson Yeah great, let us know if you find out about tools being able to handle HD, SSD and NVMe drives… :-)



  • @tom-elliott The case asset tag issue is fixed. It is displayed while the inventory task is running and it is updating the database now. Thanks Tom.

    Since there is not much we can do for the NVMe drive information, this is solved. I will continue to poke around with it and see if I can get any additional information. If I do, I will start a new topic.

    Thanks again.


  • Senior Developer

    Sorry about that, once again, rerunning installer should fix this for you. There was an overlooked element of the builder that I missed. This has since been corrected and verified. I checked inside to make sure the casesasset elements were removed. They now reference caseasset, which is the same field in the inventory table that gets called when setting up the layout. I don’t have any physical machines so I can’t say, yep this one will fix the problem for sure or anything.


  • Developer

    @jburleson Sorry I removed my post as I noticed that it looks like the fix is not being pushed yet. I sent a message to Tom to see what’s up. Marking this unsolved for now as I don’t know the current state of affairs.



  • @sebastian-roth They are the same.

    root@fog:/# sha256sum /var/www/fog/service/ipxe/init*
    7ca8048eadcaf3a408ed9d358b2636fc009dfce25b585fbf989609c87606719d  /var/www/fog/service/ipxe/init_32.xz
    58442c312bd6755bb815ff5c842656175628c99e077a69ad807a6f13a0e5bb1b  /var/www/fog/service/ipxe/init.xz
    


  • @tom-elliott I checked out the working branch and ran the installer but nothing changed. The case asset tag is still not being display or recorded in the database. I double checked that I was on the working branch.


  • Senior Developer

    The casesasset to caseasset issue should be addressed.

    If you’d like to test it just to be sure, please checkout working branch from git, and run the installer. It should force download the latest inits and kernels.


  • Senior Developer

    I’ll fix the caseasset today. The hdd thing is outside something I can fix unfortunately. If hdparm can’t read it, I don’t have a way to pull it either.


 

376
Online

41.2k
Users

11.6k
Topics

110.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.