Changing server subnet when installing on Ubuntu



  • Good afternoon,

    Been trying to get FOG installed on a clean Ubuntu 16.04 install. I’ll be running it on an established isolated net using 10.10.0.0 255.255.252.0. There is already a Windows Server 2012R2 server cluster running Domain services, DHCP, DNS, and File Services on that net. Currently I’ve got it hooked to a different net with internet access(ish, its run on a whitelist firewall that I don’t control) to install.

    The problem I’m running into is that I can’t find a way to set the subnet during install. I see where it allows me to specify the IP it will have for production, but I can’t specify a subnet. I’ve tried different options like “10.10.0.10/22” or “10.10.0.10 255.255.252.0” but it just spits back a invalid input response.

    Is there something I’m missing? Or do I just need to install using the wrong subnet, and is there a way to fix it after it’s installed?

    Thanks!!!

    Philip



  • @george1421 Figured. Thanks. Can you mark this solved? I can’t see where I can do it. I’ll open another post if I run into something else I think I need your help with. Thanks again for your assistance.


  • Moderator

    @flipwalker Yeah, unfortunately FOG needs access to your distros repositories to install OS prerequisites. The FOG side is pretty easy because it comes from a single source that can be while listed. Its the Ubuntu repositories that can be anywhere.



  • @george1421 Alright. That’s working. Unfortunately another problem that I thought might occur has come to pass. It’s nothing you guys can help with I think though. The whitelist is blocking what FOG needs to install. I’ll have to figure this out. Probably grab a wireless hotspot to connect to at least for long enough to install.

    I’ve been fighting with my superiors for months about this network being too restrictive. Ugg.

    Thanks again.


  • Moderator

    @flipwalker OK so you want your primary network adapter to be on your air gap network and the temp secondary one on your dmz. Setup the default route on the secondary network adapter so it can reach the internet. Once FOG is installed then you can remove the second network adapter (or just unplug it in case you need it for upgrades later) Setup what ever routing you need on your internal interface to reach the rest of your network. When installing FOG its important to know the linux OS name of your internal network adapter. You will be asked during the installation. That way you will be sure that FOG is binding to the right interface.



  • @george1421 I can break the airgap for install I think. Really there’s no reason other than uneducated people above me for the airgap. Lord knows I’ve broken it to update my Windows servers before… Shhhhh. ;-) I’ll go try putting another NIC in the VM attached to the other network and let you know.

    Thank you for quick responses.


  • Moderator

    @flipwalker When you install FOG don’t have fog do any dhcp or dns services for you. You will let your internal infrastructure do that for you once you swing your FOG server over to the isolated network.


  • Moderator

    @flipwalker Within your virtual environment can you make the FOG server span both network? I know if you have an air gapped network that may not be possible. If the air gap is the rule then you can just setup the fog server on the external network and we can work on changing the IP address afterwards. In the question about your subnet mask, fog itself doesn’t use a subnet mask parameter anywhere. It relies on the underlying linux OS to manage communications.



  • It is virtual, using Hyper V. I can add an additional interface if that would help. And no, the isolated network is airgapped.


  • Moderator

    Let me ask this. Is your fog server virtual and can you add a second network interface to your fog server? And/or on your isolated network do you have access to the internet via a proxy server?


 

394
Online

41.2k
Users

11.6k
Topics

110.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.