Kernel Update fails ... Oh no, not again!



  • @sebastian-roth I’ve gotten the same thing on 1.4.2, 1.4.4 and now on 1.5.0-RC-11


  • Senior Developer

    @jstephen Which version of FOG do you use?

    @sudburr Sorry for not getting back yet. Just couldn’t get to a conclusion or find a good answer. Maybe it’s a SElinux issue in your case? Have you got that disabled? Running the command getenforce shows what on your FOG server?



  • I’m having the exact same trouble. I’ve also worked through all of the steps in Troubleshoot FTP, and I also updated Fog today and applied all updates to the server OS (Debian Jesse with kernel 3.16.51-3).

    I noticed the problem updating the kernel from the web interface where I get these errors:
    Warning: ftp_mkdir(): Create directory operation failed. in /var/www/html/fog/lib/fog/fogftp.class.php on line 492

    Warning: ftp_rename(): Rename failed. in /var/www/html/fog/lib/fog/fogftp.class.php on line 769
    ##OK##

    All of my permissions look fine - fog has access to everything it needs to as far as I can tell! - and the password for the fog account is the same in all locations.



  • @george1421 said in Kernel Update fails ... Oh no, not again!:

    ls -la /var/www/html/fog/service/ipxe

    results:

    drwxr-xr-x. 2 fog    apache     4096 Jan 30 11:13 .
    drwxr-xr-x. 3 apache apache     4096 Jan 30 11:13 ..
    -rw-r--r--. 1 fog    apache     1966 Jan 30 11:13 advanced.php
    -rw-r--r--. 1 fog    apache    16272 Jan 30 11:13 bgdark.png
    -rw-r--r--. 1 fog    apache    21280 Jan 30 11:13 bg.png
    -rw-r--r--. 1 fog    apache      922 Jan 30 11:13 boot.php
    -rw-r--r--. 1 fog    apache  7601536 Jan 30 11:13 bzImage
    -rw-r--r--. 1 fog    apache  7465280 Jan 30 11:13 bzImage32
    -rw-r--r--. 1 fog    apache   234697 Jan 30 11:13 grub.exe
    -rw-r--r--. 1 fog    apache      592 Jan 30 11:13 index.php
    -rw-r--r--. 1 fog    apache 18646084 Jan 30 11:13 init_32.xz
    -rw-r--r--. 1 fog    apache 19605632 Jan 30 11:13 init.xz
    -rw-r--r--. 1 fog    apache    25340 Jan 30 11:13 memdisk
    -rw-r--r--. 1 fog    apache  1839104 Jan 30 11:13 memtest.bin
    -rw-r--r--. 1 fog    apache    20976 Jan 30 11:13 refind.conf
    -rw-r--r--. 1 fog    apache   205192 Jan 30 11:13 refind.efi
    


  • Heh… I’ve lost contact with both servers displaying this problem. 8)


  • Senior Developer

    @sudburr said in Kernel Update fails ... Oh no, not again!:

    PHP Fatal error: Uncaught Error: Call to a member function lastInsertId…

    To me this sounds as if there is an issue with the database credentials as well.


  • Moderator

    @sudburr lets start out with

    ls -la /var/www/html/fog/service/ipxe

    bzImage needs to be owned by fog or have world write access.



  • Would you please type out the exact commands you want to be tried?


  • Moderator

    @sudburr Does the linux user fog have write permissions to /var/ww/html/fog/service/ipxe and all files under?


Log in to reply
 

265
Online

7.1k
Users

14.3k
Topics

135.1k
Posts