Updating FOG Groups Not Working



  • Running Version 1.5.0-RC-10
    SVN Revision: 6080

    Issue:
    When I try to update various groups within the FOG GUI with AD details or snapins, the update doesn’t work. It says it has updated, but when I go back to the AD details page or the snapin settings, the details I added are missing. Strangely, this doesn’t happen for the first group I created - only for all subsequent ones.
    I’ve also tried cleaning the MYSQL database to no avail. Any help with this would be appreciated.



  • @tom-elliott Yes indeed, thanks very much!


  • Senior Developer

    @robtitian16 that’s intentional. Groups aren’t a consistent store for fog. Groups are simple a means to mass update hosts. If there’s no hosts in the group, then there’s nothing to update. I could update groups to store the information locally, but that information would not necessarily be applied to all hosts in the group. This is why it checks all hosts in the group and presents the common data within a group. Hopefully all that makes sense.


  • Senior Developer

    @robtitian16 that’s intentional. Groups aren’t a consistent store for fog. Groups are simple a means to mass update hosts. If there’s no hosts in the group, then there’s nothing to update. I could update groups to store the information locally, but that information would not necessarily be applied to all hosts in the group. This is why it checks all hosts in the group and presents the common data within a group. Hopefully all that makes sense.



  • @wayne-workman Indeed, it’s a follow on from my previous thread here: https://forums.fogproject.org/topic/11308/hostname-changer-access-denied-code-5/19

    Seabastian Roth asked that I create a new one.

    @Tom-Elliott Ah, that’s interesting… my other groups have 0 members, but I’ve just added 2 to one of the groups known to not be working, updated the AD details, and now it’s saved the changes!
    So, is that intentional? Or is that still classified as a bug?


  • Senior Developer

    The fields when updated are applied to the hosts in the groups. If the groups hosts all have the same information, they should kind of, the data will be populated to the group. There is possibly a bug in seeing the data itself, but do the hosts in the group actually contain your update at least?



  • @robtitian16 This bug has been reported before - but I don’t have a lot of time at work to find the other thread.


 

515
Online

41.9k
Users

12.5k
Topics

117.6k
Posts