Error deploying old image with partimage



  • I am running 1.5.0 RC 11 and since few update, I have this error.

    0_1516955488912_IMG.jpg

    Here are the files in the directory of the image.

    0_1516955519413_704177fa-af2d-4357-a17a-472a8b9c745c-image.png


  • Developer

    @jmeyer I don’t seem to be able to explain this properly. I am not talking about disk size and start sectors although this might be an issue as well. But even if you get this right it still might not be able to boot in the VM as of difference in (virtual) hardware.

    By the way, is your image UEFI or legacy MBR? Configure your VM accordingly.



  • @sebastian-roth I don’t think to go in the wrong direction about the 63s.
    Here is what I have from command line on working computer :

    DISKPART> detail partition
    
    Partition 1
    Type   : 07
    Masqué : Non
    Active : Oui
    Décalage en octets : 32256
    
      N° volume   Ltr  Nom          Fs     Type        Taille   Statut     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
    * Volume 1     C                NTFS   Partition    232 G   Sain       Système
    

    How I can get same result from debug task ?
    I tried making the partition with parted (mkpart primary 63s 100%) but without success on booting computer.



  • I tried setting 63 as first sector using command “fdisk -c=dos /dev/sda” in debug but it’s not working at the end. I must have missed something.



  • @sebastian-roth HDD size is one problem link to hardware but I think OS boot is more about first sector of the partition.
    I remember that my old Windows 7 image were build as windows XP and doesn’t start at 2048 but 63.
    Thomas had fixed this before but I think he has probably reverted changes.

    How can i check this ?


  • Developer

    @jmeyer As I don’t know which VM software you use (virtualbox, vmware, hyper-v, xenserver, kvm, …) I can’t give specific information. What I mean is VMs usually emulate specific disk controllers and other things that most probably differ from what you have as hardware in your physical client. So the drivers in your windows installation fail to work.

    For VMware for example there is a software called “VMware vCenter Converter Standalone” that helps you in moving from a physical machine to a virtual machine.



  • @sebastian-roth It deploy fine on the 300GB VM drive or a 1 TB drive.
    I have a black screen with a blinking underscore on the VM.
    On a computer, It’s write “A disk read error occured”.


  • Developer

    @jmeyer So it does deploy to the 300 GB VM disk? No partimage error?

    What do you see on screen when trying to start the VM? I guess that might be a driver issue. It’s not as easy as deploying an image to any machine or even VM.



  • @tom-elliott It’s a new HDD. I have tried on a VM with a 300GB HDD and I think image is corrupt because it doesn’t boot after deploy.


  • Senior Developer

    @jmeyer Has this image been able to be deployed to this same type of hdd in the past?

    Based on the size difference (less than a megabyte) it seems to me the HDD of the receiving drive is just a TINY bit smaller than what was to be expected. It also appears the hdd is about 250GB? Just guessing here.



  • @sebastian-roth It’s an old image so i am not sure but I think it is one.


  • Developer

    @jmeyer Is this a resizable image type?



  • I have tried to run partimage in debug and it says that partition is too small to be restored.
    Original size is : 250059317760 and destination size is 250058301440.

    Is there a way to bypass this ?


 

406
Online

41.6k
Users

12.1k
Topics

114.4k
Posts