Black screen when attempting to Perform full registration and inventory on Dell Latitude 5580



  • Hi all,

    FOG 1.4.4, Kernel: bzImage Version: 4.13.4, bzImage32 Version: 4.13.4

    Using Dell Latitude 5580. If I attempt to boot from the network, and choose either Legacy or UEFI booting over the network, then choose “Full host registration and inventory”, I am presented with a black screen.

    I can perform a Quick Registration, then rename the host within the web interface (among the other options). The goal is to do the registration, image selection, group selection, all in one area.

    I know the Latitude 5580 will image, as I’ve been working with them for the past few weeks. But the full host registration seems to not work when booting from the network on these devices.

    Thoughts?



  • @george1421 I’m 99% sure it was the suggestion of something I found on the forums a long time ago, but simply forgot.

    Like I said, once everything calms down, I’m planning on rebuilding my FOG machine anyways, and blast away old images, especially since I can drop driver packs in now :)


  • Moderator

    @lukebarone Hey, we are glad you found it because we couldn’t understand how this was only happening for full registration.

    In the future don’t add kernel parameters in the ipxe menu. Either add them globally in the fog configuraitons page or targeted in the host configuration page. Either way great job finding it.



  • @tom-elliott Me are stupid -.-

    Under the Fog Configuration -> iPXE Menu Configuration -> fog.reginput -> Boot Options:, I had " pci=noacpi" added for some reason. I removed it (after seeing that it wasn’t there on Quick Registration), and I can now boot directly to the Registration screen!

    I can’t wait for the spare time to just rebuild a FOG server from scratch and copy over the machines I need… -.- Sorry to have wasted so much time with everyone on this issue


  • Senior Developer

    @sebastian-roth The public certificate is regenerated every install, and that’s the only file stored in management/other/ (the public certificate for the private key).


  • Developer

    @lukebarone said in Black screen when attempting to Perform full registration and inventory on Dell Latitude 5580:

    I guess the other question is, can I just simply delete one of the FOG folders, and it would be “uninstalled”?

    In theory you can. But which one is the most current one? I’d suggest backing up and the deleting both. Then re-run the installer to have a fresh clean one. If you have the fog-client in use you better put the certificate stuff in place again after the installer is done (you find that in ....../management/other/).



  • @sebastian-roth I guess the other question is, can I just simply delete one of the FOG folders, and it would be “uninstalled”?



  • @sebastian-roth

    uname -a
    Linux fogclient.localdomain 4.13.4 #2 SMP Oct 18 15:26:04 EDT 2017 x86_64 GNU/Linux
    

    So it is grabbing the new Kernel that was installed…


  • Developer

    @lukebarone As Tom said it looks like your web directory has at least two different versions of FOG running. This can cause an issue I reckon.

    To see which kernel version you really have when booting up a client please schedule a debug task and run uname -a when you get to the shell.



  • @george1421 Just for S&G’s, I went into the Fog Debug menu. Running an ls on the /bin/ folder, I see a bunch of fog scripts. Do you want me to manually try running the fog.man.reg script from the shell? Would that help with what works and what doesn’t?

    EDIT: I tried executing fog.man.reg from the Debug menu. Entered the information, selected the image / group / snapins / other configurations, and then rebooted. It grabbed the image automatically, as expected.

    So it seems there is a disconnect between the boot menu option for “Full Host Registration” vs going into Debug, and manually executing the script.


  • Moderator

    @lukebarone Well nuts, we typically see that people when the upgrade from 0.30 to 1.30+ they leave the boot file to pxelinux.0 That file will cause an issue between bzImage and init.zx

    We are wHittling down the list of suspects to either 1. That workstation is crap 2. Your fog server needs to be junked and rebuilt from the ground up. I’m leading toward #1.

    I’m not sure this next suggestion is going to help any. But I wonder if there is another bad actor involved with the pxe booting process? Like a proxydhcp server. At this point I am running out of ideas. We could capture a pcap of the pxe booting process but I’m not sure if that will give us any additional information we don’t already have.



  • @george1421

    if substring (option vendor-class-identifier, 15, 5) = "00000" {
            # BIOS client
                filename "undionly.kpxe";
            }
    #    elsif substring (option vendor-class-identifier, 15, 5) = "00006" {
    #        # EFI client 32 bit
    #        filename   "ipxe32.efi";
    #    }
            else {
                # default to EFI 64 bit
                filename   "ipxe.efi";
            }
    

    I do not have any 32-bit UEFI machines, so I disabled that one section. I think that since I see the menu, it is grabbing one of those two files successfully…?


  • Moderator

    Well I managed to get my fog serever/kernel updated to 4.13.4 thinking that the newest kernel had a bug, but that also boots on the 7280 into full registration.

    … wait a second. You said you had 0.30 not too long ago. What exactly do you have configured for dhcp option 67 {boot-file}?



  • @tom-elliott Hopefully this helps:

    /var/www/html/fog/service/ipxe# file bzImage32
    bzImage32: Linux kernel x86 boot executable bzImage, version 4.13.4 (root@debian64) #2 SMP Wed Oct 18 15:27:21 EDT 2017, RO-rootFS, swap_dev 0x7, Normal VGA
    root@fog-bak:/var/www/html/fog/service/ipxe# ls -lah
    total 53M
    drwxr-xr-x 3 fog      www-data 4.0K Jan 23 09:51 .
    drwxr-xr-x 3 www-data www-data 4.0K Jan 23 09:06 ..
    -rw-r--r-- 1 fog      www-data 2.0K Jan 23 09:06 advanced.php
    drwxr-xr-x 2 fog      fog      4.0K Jan 23 09:51 backup
    -rw-r--r-- 1 fog      www-data  16K Jan 23 09:06 bgdark.png
    -rw-r--r-- 1 fog      www-data  21K Jan 23 09:06 bg.png
    -rw-r--r-- 1 fog      www-data  922 Jan 23 09:06 boot.php
    -rwxr-xr-x 1 fog      fog      7.7M Jan 23 09:51 bzImage
    -rwxr-xr-x 1 fog      fog      7.5M Jan 23 09:51 bzImage32
    -rw-r--r-- 1 fog      www-data 230K Jan 23 09:06 grub.exe
    -rw-r--r-- 1 fog      www-data  592 Jan 23 09:06 index.php
    -rw-r--r-- 1 fog      www-data  18M Jan 23 09:06 init_32.xz
    -rw-r--r-- 1 fog      www-data  19M Jan 23 09:06 init.xz
    -rw-r--r-- 1 fog      www-data  25K Jan 23 09:06 memdisk
    -rw-r--r-- 1 fog      www-data 1.8M Jan 23 09:06 memtest.bin
    -rw-r--r-- 1 fog      www-data  21K Jan 23 09:06 refind.conf
    -rw-r--r-- 1 fog      www-data 201K Jan 23 09:06 refind.efi
    
    /var/www/html/fog/service/ipxe# cat /etc/apache2/sites-enabled/001-fog.conf
    NameVirtualHost *:80
    <VirtualHost *:80>
        KeepAlive Off
        ServerName 192.168.0.4
        DocumentRoot /var/www/html/
        <Directory /var/www/html/fog/>
            DirectoryIndex index.php index.html index.htm
        </Directory>
        RewriteEngine On
        RewriteCond %{DOCUMENT_ROOT}/%{REQUEST_FILENAME} !-f
        RewriteCond %{DOCUMENT_ROOT}/%{REQUEST_FILENAME} !-d
        RewriteRule ^/(.*)$ /fog/api/index.php [QSA,L]
    </VirtualHost>
    
    /var/www/html/fog/service/ipxe# ls /etc/apache2/sites-enabled/ -la
    total 8
    drwxr-xr-x 2 root root 4096 Jan 23 09:06 .
    drwxr-xr-x 8 root root 4096 Sep 25 13:35 ..
    lrwxrwxrwx 1 root root   31 Jan 23 09:06 001-fog.conf -> ../sites-available/001-fog.conf
    
    

    I only see the single site configuration in Apache’s sites-enabled directory, so I assume this is the correct directory that it’s using.



  • @george1421 said in Black screen when attempting to Perform full registration and inventory on Dell Latitude 5580:

    I was able to register the 7080 just fine. I did have to turn off secure boot, and switch the hard disk mode to achi to get FOS to see it. Understand that what I see is not exactly what you are seeing. Your version of the kernels are much newer than mine (I’m running 1.4.4 too) and your hardware is different. I did see where you say the cursor just flashes and nothing, mine did that but then the kernel booted and continued.
    I’m going to reinstall FOG 1.4.4 on mine to see if its picks up the newer kernels. But just to confirm you didn’t do anything other than install fog? You didn’t update anything beyond installing FOG?

    Yes, I went to the Kernel Update page and selected the newest kernel… It’s a habit I picked up a while ago, but if it’s not recommended, I can run through the install again and let it keep the version that comes with the install script…?

    And Secure Boot is still disabled; I never enabled it, and it was disabled by default out of the box


  • Moderator

    @george1421 I was able to register the 7080 just fine. I did have to turn off secure boot, and switch the hard disk mode to achi to get FOS to see it. Understand that what I see is not exactly what you are seeing. Your version of the kernels are much newer than mine (I’m running 1.4.4 too) and your hardware is different. I did see where you say the cursor just flashes and nothing, mine did that but then the kernel booted and continued.

    I’m going to reinstall FOG 1.4.4 on mine to see if its picks up the newer kernels. But just to confirm you didn’t do anything other than install fog? You didn’t update anything beyond installing FOG?


  • Moderator

    Well let me say, this is CRAZY!!

    I have a 7280 on my desk for another project, lets make sure I can perform a full registration in FOG.


  • Senior Developer

    @lukebarone based on what I’m seeing you have 2 installations of fog on your machine. I don’t know which is the default for your setup.



  • @george1421 Restarted the computer, boot via UEFI PXE. Select Full Host Registration and Inventory, and it’s still just sitting there :(


  • Moderator

    @lukebarone well that is much more consistent than what you had before. I was thinking that 4.13.6 was the very latest, but lets see how well this one works with the 5580s.

    Never mind I was thinking 4.11.6 which I had to install on my production server to make the surface books to work. Your version is much later.


 

569
Online

5.4k
Users

12.6k
Topics

118.8k
Posts