TFTP/FTP Issues after cloning success



  • Hi guys. Back again with some new issues. So I had to do a clean install of Ubuntu and Fog and I’ve managed to get everything working up until it’s time to update the database with the image file after a capture task is complete.
    0_1516300573147_fogftpfail.PNG

    0_1516300590753_fogftpfail2.PNG

    So I have tried “passwd fog” and “passwd -d fog” and retried but the issue persists. The weird thing is that there wasn’t a home folder created for the Fog user initially so I created one and tried again to no prevail.

    I’ve had a look past previous forums too and tried some solutions but nothing seems to work. I’m on the latest updated version. So there’s clearly an issue with ftp/tftp here trying to access the server through the Fog user. I changed the default Fog user and password instantly after setup but I also created a new user named Fog when trying to troubleshoot this but there’s no success.

    Really appreciate the help guys. Thanks in advance!



  • @wayne-workman @george1421 It worked! in hindsight I should have just changed the management user, my bad.

    Thanks again!


  • Moderator

    someone mess with the linux service account (user) called fog? That’s not the default web admin with the same name. What I’m talking about is the linux user called fog. That account is (should be) managed by FOG and not used for system maintenance.



  • Thanks for the quick reply. I spent so long trying to modify everything so the Fog user was being used for TFTP but then I decided to edit everything for the user I set on startup. Running now so hopefully it works.

    Appreciate the time you guys take to comment so quickly!



  • Our wiki has this covered: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP
    Let us know if you need more help.


 

451
Online

5.4k
Users

12.6k
Topics

118.9k
Posts