FOG Management Console not accessible from other computers.



  • I will be as brief and detailed as I possibly can.

    I am running CentOS 7 with Fog server version 1.4.4 SVN 6077.

    The issue I am running into is that on the Fog server itself (10.10.0.65) I can open the management console. When i go any other computer I cannot access the console. I can ping the computer from everyone, just can’t access the console.

    There is another issue which I believe is related and that is that when i attempt to do the PXE boot i get the error "http://10.10.0.65/fog/service/ipxe/boot.php/…Connection timed out (http://ipxe.org/4c0a6035). I already checked the “defualt.ipxe” folder and made sure the IP is correctly listed inside.

    My assumption is that there is that there is something i missed or overlooked that is preventing other computers on this network from accessing the fog server.

    Let me know if there is anything I may have overlooked, ideas, or if you need more info.
    Thank you in advance.


  • Moderator

    @jjsplitter Since you still had firewalld enabled, did you remember to set selinux to permissive? If not you will have a sad time when you try to capture an image.



  • @george1421 I am now able to get past the other error during the PXE boot and I can see the FOG menu screen (where you deploy images and or create host registrations).

    You’re the best!



  • @george1421 Holy mother of everything. That worked. I can access the management console from my own computer now.

    Now to test and see if the images will work now.

    Thank you x1000!


  • Moderator

    It looks like the instructions from the wiki came from here: https://forums.fogproject.org/topic/6162/firewall-configuration

    If you need to leave firewalld running then you will need to enable exceptions to the block all policy. I know that you have that script, but my guess is that you don’t have samba installed and that is why its failing.

    This script

    for service in http https tftp ftp mysql nfs mountd rpc-bind proxy-dhcp samba; do firewall-cmd --permanent --zone=public --add-service=$service; done
    systemctl restart firewalld.service
    

    can be rewritten as:

    firewall-cmd --permanent --zone=public --add-service=http
    firewall-cmd --permanent --zone=public --add-service=https
    firewall-cmd --permanent --zone=public --add-service=tftp
    firewall-cmd --permanent --zone=public --add-service=mysql
    firewall-cmd --permanent --zone=public --add-service=nfs
    firewall-cmd --permanent --zone=public --add-service=mountd
    firewall-cmd --permanent --zone=public --add-service=rpc-bind
    firewall-cmd --permanent --zone=public --add-service=proxy-dhcp
    firewall-cmd --permanent --zone=public --add-service=samba
    

    Again I think its the samba that is causing the query to fail



  • That is the exact tutorial i followed when i was setting up CentOS and FOG. The only part i was not able to complete was:

    for service in http https tftp ftp mysql nfs mountd rpc-bind proxy-dhcp samba; do firewall-cmd --permanent --zone=public --add-service=$service;
    done

    This kept giving me an error of: “Error: INVALID_SERVICE: " " not among existing services”.

    My FOG server is also not responsible for DHCP so I am not sure if this is needed either way.

    Thank you,
    Justin



  • @jjsplitter Firewalld, SELinux. The correct configurations for those things is in our CentOS 7 tutorial.


 

434
Online

41.8k
Users

12.3k
Topics

116.1k
Posts