Chainloading failed



  • Hi, so I ran into some trouble earlier to register a host (https://forums.fogproject.org/topic/11221/failed-to-get-an-ip-via-dhcp)
    which is now working but now I have a new issue.
    When booting from the network, on the PXE menu, choosing boot from the hard drive get me the following message :

    “Chainloadinf failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds”
    alt text

    However booting from the HDD directly (without PXE) works just fine

    FOG: 1.4.4
    Server: Debian 9



  • Ok I solved it.
    Yes, that is when I let the menu timeout.
    In my host the : FOG_EFI_BOOT_EXIT_TYPE and FOG_BOOT_EXIT_TYPE were both set to EXIT, Ichanged them back to the default setting (‘Please select an option’) and set those parameter to SANBOOT in the fog settings.

    Thank you for your help :D


  • Developer

    @Arkhad Ok, let’s tackle this one then! :-)

    Do I get this right? This happens when you let the FOG menu timeout to boot from HDD?

    Is this machine set to legacy BIOS or UEFI? Take a look at the “exit style” settings in the FOG web UI. There are general settings (FOG Configuration -> FOG Settings -> …) for legacy BIOS and UEFI as well as settings for each host in the host’s settings. Play with those settings to see if you can make it work.


 

517
Online

5.4k
Users

12.6k
Topics

118.8k
Posts