rEFInd - Initializing after disable Secure boot



  • Hello
    Disable secure boot, I got an error after loading from network

    Exit to Hard Drive Type - SANBOOT
    Exit to Hard Drive Type(EFI) - REFIND_EFI

    You are currently running version: 1.5.0-RC-10

    0_1512033355237_a8b7c6e8-f1a2-461b-a9d3-d28d3f235236-image.png



  • @poizzon said in rEFInd - Initializing after disable Secure boot:

    Partition 1 System 499 MB 1024 KB

    Today I made a test with VMware Workstation with a blank disc and turned UEFI function.
    I got the same error.

    p.s.: after instaling WIndows, and tryng boot from network - same situation



  • @george1421 it is genuine Dell partition schema

    DISKPART> list disk
    
      Disk ###  Status         Size     Free     Dyn  Gpt
      --------  -------------  -------  -------  ---  ---
      Disk 0    Online          465 GB      0 B        *
    
    DISKPART> select disk 0
    
    Disk 0 is now the selected disk.
    
    DISKPART> list partition
    
      Partition ###  Type              Size     Offset
      -------------  ----------------  -------  -------
      Partition 1    System             499 MB  1024 KB
      Partition 2    Reserved           128 MB   500 MB
      Partition 3    Primary            455 GB   628 MB
      Partition 4    Recovery           939 MB   455 GB
      Partition 5    Recovery             8 GB   456 GB
    
    DISKPART> list volume
    
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     C   OS           NTFS   Partition    455 GB  Healthy    Boot
      Volume 1         ESP          FAT32  Partition    499 MB  Healthy    System
      Volume 2                      NTFS   Partition    939 MB  Healthy    Hidden
      Volume 3         Image        NTFS   Partition      8 GB  Healthy    Hidden
    
    DISKPART> detail disk
    
    WDC WD5000LPLX-75ZNTT0
    Disk ID: {CF2E2F9A-2807-46A7-889D-FA8A5A099BB1}
    Type   : RAID
    Status : Online
    Path   : 0
    Target : 0
    LUN ID : 0
    Location Path : PCIROOT(0)#PCI(1700)#RAID(P00T00L00)
    Current Read-only State : No
    Read-only  : No
    Boot Disk  : Yes
    Pagefile Disk  : Yes
    Hibernation File Disk  : No
    Crashdump Disk  : Yes
    Clustered Disk  : No
    
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     C   OS           NTFS   Partition    455 GB  Healthy    Boot
      Volume 1         ESP          FAT32  Partition    499 MB  Healthy    System
      Volume 2                      NTFS   Partition    939 MB  Healthy    Hidden
      Volume 3         Image        NTFS   Partition      8 GB  Healthy    Hidden
    
    
    

    0_1512065783149_e762ac7f-c238-4452-b320-0a6ddc1c3c03-image.png


  • Moderator

    @poizzon The Secure boot question is only an issue related to pxe booting non-microsoft operating systems. With secure boot on, only operating systems with a valid certificate can boot on that hardware. So secure boot only impacts booting linux and iPXE on the target computer and not the quality of the image on the target computer.

    Can you take one of these non-refind-booting systems and boot it into windows and then do a print screen of the disk manager table partition layout and post the picture here? I would be interesting in seeing what the disk geometry looks like,



  • @george1421 All computers are Dell’s :
    Latitude E5570
    PowerEdge T20

    As I remember installation of this computers was made with secure boot enabled.
    Maybe I had to install with the option turned off secured boot ?

    Partitions are GPT


  • Moderator

    @poizzon I think here we have 2 issues.

    1. The system is setting at the refind menu, where you pick enter and it boots into windows.
    2. The system doesn’t discover any efi boot partitions on the computer so it posts your earlier message.

    In regards to the computer that doesn’t find any efi boot partitions, what hardware is this Manufacturer and model?



  • @george1421 I think this menu is not a problem, as I understand it is due to scanfor …

    by default are set like you say

    ....
    timeout -1
    ....
    scan_delay 5
    ....
    

  • Moderator

    @poizzon

    Here is a repeat of a post helpfully provided by @Enrico

    Those settings fit more situations, I think (but I can’t assure that) but you can tune them.
    
    scanfor selects where it is going to search for boot loaders. In my case, “internal” does not find bootcamp boot loader, so I add “hdbios”.
    
    scandelay 5 is needed because the default 0 is too quick to permit the bootcamp become available.
    
    timeout 5 is needed because the default -1 goes straightforward to boot the default loader and does not show the two os options. So, this one is needed if you have a multiboot system only.
    

    In your case, check scandelay and set it for 5, and then timeout to -1 to pick the default boot loader without delay. Yes I understand the post was about OSX (Apple), but UEFI is UEFI.



  • i don’t wait.
    just pressing enter and booting to windows normaly.


  • Moderator

    @poizzon This menu we can work with. If you wait for a period of time does the system boot?



  • changed, but it did’t help

    #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    #scanfor internal,hdbios
    #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    scanfor internal
    

    on some pc’s sometimes got another screens after initializing, after presing enter - booting corectly to windwows :

    0_1512050995113_1b22a71c-96d1-4462-972a-ea36c074bcd5-image.png


  • Developer

    @poizzon Edit /var/www/fog/service/ipxe/refind.conf on your FOG server. Find the line that looks like this:

    ...
    scanfor  internal,hdbios
    ...
    

    Remove the ,hdbios part of that line, save and try again.



  • There is no bitlocker.

    At this moment I don’t remember if legacy boot is enabled…

    After pressing “any key” pc starting normally.


  • Moderator

    This one is interesting.

    First if this is a bitlocker protected drive then you will have an issue with secure boot disabled. Also FOG can not correctly copy a bitlocker protected drive.

    From the error above, to translate it. The error says your firmware doesn’t have legacy roms enabled. It can’t find any legacy hardware to boot from. This kind of tells me that refind is unable to locate an efi partition to boot from. So while the error message is telling a story, I don’t think that is the root of your issue here.


Log in to reply
 

453
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.