Broadcom Corporation NetXtreme II BCM57711E 10-Gigabit PCIe unable to load firmware with FOS



  • Hi Guys,

    FOS is failing to load the firmware for BCM57711E 10GBE which is installed on most of blades ( ProLiant BL460c G6) inside the HP BladeCenter c7000.
    I had a similar issue in the past with dell blades m620 and another 10gbe Broadcom card, Tom Eliot was so kind to update FOS around the August timeframe and included the fix:
    sudo mkdir -pv /var/www/fog/service/ipxe/backup
    sudo mv -v /var/www/fog/service/ipxe/bzImage* /var/www/fog/service/ipxe/backup
    wget -O /var/www/fog/service/ipxe/bzImage https://fogproject.org/kernels/bzImage
    wget -O /var/www/fog/service/ipxe/bzImage32 https://fogproject.org/kernels/bzImage32

    here are the details from FOS dmesg for the failed firmware load:
    0_1511095137102_Capture.PNG
    lscpi :
    02:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM57711E 10-Gigabit PCIe
    02:00.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM57711E 10-Gigabit PCIe

    Are you able to kindly update the FOS with BCM57711E firmware ?

    Thanks in Advance,

    Aviram



  • Thanks Guys, I can confirm its working now.

    Aviram


  • Senior Developer

    @jones We have updates the kernels, if you update your copies of them it should work.


  • Developer

    @jones Sorry we missed your post! Just too much happening and too little time.

    We do add firmeware binary blobs as people ask specifically to do so. We can add this one for you, no problem. @Tom-Elliott does the kernel updates, though he’s real busy. See when he gets to it.

    Which version of FOG do you use right now?


 

458
Online

41.4k
Users

11.8k
Topics

112.1k
Posts