WOL FOG 1.4.4



  • Hello,

    I am using fog 1.4.4 everything works fine expect the WOL function.
    I use the WOL plugins for my network broadcast.
    I can WOL all the machine with the manually test http://“MYIP”/fog/management/index.php?sub=wakeEmUp&mac=MYMAC
    But with the web interface on deploy task or basic tack -> advanced -> wakeup there no issues.
    With fog 1.2.0 WOL works fine with add of the broadcast in the wol.php.

    Debian 8 fog 1.4.4
    Any idea.
    Thanks.



  • @cedre It works ok for the other VLANS?



  • @wayne-workman
    The router is OK it works perfects with the manually test on fog 1.4.4 http://“MYIP”/fog/management/index.php?sub=wakeEmUp&mac=MYMAC.



  • @cedre For the WOL plugin to work correctly, you have to allow broadcast traffic through your router(s), or something like that anyways. There are threads here in the forums about it.



  • @wayne-workman

    In fog 1.2 i modified the file WakeOnLan.class.php and the wol is OK.
    if(socket_set_option($soc, SOL_SOCKET, SO_BROADCAST, TRUE))
    {
    $vlan=array(‘vlan12’ => ‘x.x.x.255’,
    ‘vlan13’ => ‘x.x.x.255’,
    ‘vlan17’ => ‘x.x.x.255’,
    ‘vlan19’ => ‘x.x.x.255’,
    ‘vlan20’ => ‘x.x.x.255’,
    ‘vlan25’ => ‘x.x.x.255’,
    ‘vlan50’ => ‘x.x.x.255’,
    ‘vlan144’ => ‘x.x.x.255’,
    ‘vlan401’ => ‘x.x.x.255’,
    ‘vlan403’ => ‘x.x.x.255’,
    ‘vlan404’ => ‘x.x.x.255’,
    ‘vlan504’ => ‘x.x.x.255’);
    In fog 1.4.4 I use WOL Plugins with no success
    I already apply the patch for WOL plugins.



  • I’ll test WOL in 1.4.4 when I get home this evening.


  • Developer

    @cedre said in WOL FOG 1.4.4:

    With fog 1.2.0 WOL works fine with add of the broadcast in the wol.php.

    What exactly do you mean by that?


 

373
Online

41.9k
Users

12.4k
Topics

116.8k
Posts