Fog Install - Blank Screen when update database



  • I have installed Fog 1.4.0 on CentOS 7 running on vmware. The problem is when I get to the update database part where you go to ipaddress/fog/management, I only get a blank screen.

    I went ahead and hit enter and finished up the install. Any help would be appreciated.

    Thank you,
    Tamara



  • @sebastian-roth Thanks so much! That worked. ( I had those pre-config settings before when I ran the 1.4.0; however, I had reverted to a previous snapshot and didn’t re-configure them for round 2).

    Thanks again,
    Tamara


  • Developer

    @tlamb said:

    SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    

    Well, there we go. Read through our CentOS 7 install article in the wiki and pay special attention to the section “Continue pre-config” where it talks about firewall rules and disabling SELinux! After you’re setup things right, reboot the maschine an re-run the 1.4.4 installer. You should be up and running then.



  • @sebastian-roth

    After running the install.sh for 1.4.4 , still returning a blank screen. Here is the error log :

    [root@ofmq-foggy httpd]# vi error_log
    [Sun Oct 29 18:30:41.037862 2017] [core:notice] [pid 20350] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Sun Oct 29 18:30:41.041267 2017] [suexec:notice] [pid 20350] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::250:56ff:fe96:9a92. Set the 'ServerName' directive globally to suppress this message
    [Sun Oct 29 18:30:41.114321 2017] [auth_digest:notice] [pid 20350] AH01757: generating secret for digest authentication ...
    [Sun Oct 29 18:30:41.116461 2017] [lbmethod_heartbeat:notice] [pid 20350] AH02282: No slotmem from mod_heartmonitor
    [Sun Oct 29 18:30:41.334419 2017] [mpm_prefork:notice] [pid 20350] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.6.32 configured -- resuming normal operations
    [Sun Oct 29 18:30:41.334498 2017] [core:notice] [pid 20350] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    

  • Developer

    @tlamb If you still get the blank screen take a look at the apache error logs (see my signature) and post here.



  • @wayne-workman Thanks, I will try that. I didn’t notice i wasn’t installing the latest.



  • @tlamb Version 1.4.4 is the latest, please try that.


 

370
Online

41.7k
Users

12.2k
Topics

115.1k
Posts