WOL not working from nodes anymore 1.4.4



  • I have fedora 26 running FOG 1.4.4. Wol used to work fine from the nodes as they are all in there own subnets, and I have a node installed on that subnet. Recently it seems that WOL just stopped working and I’m not sure why. This is what I get from apache error log.

    [Mon Oct 23 12:15:00.904516 2017] [http2:warn] [pid 30424] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
    

    is this error worth worrying about or are there any fixes. I’ve tried the manual wake up with the url to no avail either.
    Please help.


  • Moderator

    @hanz Thank you very much for your feedback.



  • @george1421

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power\

    Value
    HiberbootEnabled

    REG_DWORD set to 0 hex


  • Moderator

    @hanz If you wouldn’t mind, please expand on what you had to set in the GPO to correct this. Your solution will probably help the next FOG Admin who’s pulling his hair out trying to understand what happened…



  • @hanz WOL verified with wireshark being sent and found the culprit to be fastboot with Windows 10.

    Registry gpo and viola ! Thanks fellas for ruling some things out.


  • Moderator

    @hanz said in WOL not working from nodes anymore 1.4.4:

    Can you verify that power management and Wake via Basic Tasks–> Advanced --> Wake-Up are the exact same ?

    The current FOG Server engine is complex to understand really. It is very abstracted at many points and it just doesn’t click for me. :-\

    You could always use an old hub to do a packet capture between the host and server. It’s important to use a HUB and not a Switch - because a hub will forward all packets to all ports, a cheap switch won’t.



  • @wayne-workman I’m actually curious how I could verify that the nodes are sending the packets on command ? I have 7 nodes in different subnets, and not 100% certain this was working on this version (although I’ve not seen any issues posted). I can verify at the beginning of summer it was working, but not sure what version and when beyond that scope.

    Can you verify that power management and Wake via Basic Tasks–> Advanced --> Wake-Up are the exact same ?


  • Moderator

    @hanz said in WOL not working from nodes anymore 1.4.4:

    WakeMeOnLan isn’t even working locally, although I was told otherwise earlier today.

    I’m guessing this is the utility you found to test WOL outside of FOG. If that’s not working, this isn’t a fog problem.



  • @wayne-workman Manually this is the page it took me to.

    #!ipxe
    set fog-ip X.X.X.X
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x1b
    iseq ${platform} efi && set keyName ESC || set keyName Escape
    prompt --key ${key} --timeout 5000 Booting… (Press ${keyName} to access the menu) && goto menuAccess || chain -ar ${boot-url}/service/ipxe/grub.exe --config-file=“rootnoverify (hd0);chainloader +1”
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://X.X.X.X/fog/service/ipxe/boot.php##params

    I subbed the ips for X, and no wake, nor with WakeOnLan though so not sure…No change in network at all, but we are running SCCM current branch now, which was the only change now that I think about it.

    ::Update
    WakeMeOnLan isn’t even working locally, although I was told otherwise earlier today. Might have some issues…I believe it was still 1.4.4 end of summer was still working. Upgraded OS to fedora 26 and moved server from physical to Hyper-V, but all other aspects working of course.


  • Senior Developer

    The fact that it worked, then stopped working seems to me to not be FOG related. I’m assuming you mean it even worked while on the same exact version of fog, just it stopped working one day. Did anything in the networking environment change? Switches, multicast settings, udp settings, etc…?


  • Moderator

    @hanz Try to issue a call to the FOG server’s WOL route directly: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_Web_Interface#Manually_test_WOL

    See if that wakes them up or not. If that works, we have an issue. If not, go find a WOL utility and see if that wakes them up or not - if this fails, it’s not fog’s problem - if it works, we have an issue.


Log in to reply
 

429
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.