Image Size: ON Server 0.00 iB - Was working but now its not.



  • I know I know, another image size on server thread. I read through all the previous threads I could find and it helped me the first time I ran into this issue but now it’s broken again. So I uploaded my first ever image with FOG and and ran into the issue were it displayed 0.00 iB. I fixed it the first time by following the Wiki and updating all the different places to have the same user and password. After that I messed around with the web server so that when I went to the root webpage it would pull up the management portal and not the default apache page. Now I uploaded my second image and it shows 0.00 iB but the first image shows 14.64 GiB. I verified that the folder for the second image was owned by the “fog” user. I can still TFTP in with those credentials and I went ahead and retyped the user and password again in all the previous locations to no avail. What could the problem be?



  • @tom-elliott Great! Thanks, will do.


  • Senior Developer

    @ravigon No problem.

    I would also check if the FOGImageSize service is enabled which you should be able to do with:

    sudo systemctl enable FOGImageSize

    This should ensure it can start on reboots.



  • @tom-elliott The IP did change at some point. It was assigned by DHCP when I first installed Ubuntu but I created a reservation for it on the DHCP server afterward with a different IP. I just cannot recall if I changed it before or after installing FOG. Since I will be needing multicast in the future, I did some reading and found where it said to change the hosts file (located at /etc/hosts) IP entry for my server hostname from 127.0.0.1 or 127.0.1.1 to my current static IP and then restart the multicast service (sudo systemctl restart FOGMulticastManager). Now the multicast log is showing “No Tasks Found!”. Success! Thanks again for all your help!

    Edited to give more info on the multicast fix.


  • Senior Developer

    @ravigon 127.0.0.1 is not the proper IP address at all. That means to literally reference itself.

    While 127.0.0.1 is the “node” itself, it almost sounds like the IP that was configured during initial install has changed from what the new network IP address is.



  • @tom-elliott That did it! I wonder why even after rebooting the server it didn’t work? On a side note I was looking at the Multicast log and it also showed the master node error message. So on a hunch I changed the IP on the storage node from my internal static IP to 127.0.0.1. After that the Multicast log said “No Tasks Found”, which I’m taking as a good sign as that it can read the storage node. I changed the IP back to the static IP on the storage node and then ran the command to restart the service and it now displays the image file sizes for the two new images. My question is should I leave the static IP on the storage node or set it to 127.0.0.1? Thank you all for the help!

    Current Status:
    Image Size: On Server - Functioning
    Multicast Log - Showing “This is not the master node”


  • Senior Developer

    @ravigon Please try:

    systemctl restart FOGImageSize
    

    Followed by:

    systemctl status -l FOGImageSize
    


  • @tian igaPrimary also has them all set to 1. Under Storage Management the group is set to Default (1). The other settings all look to be correct including the user and password. In the log I am seeing this over and over again: “This is not the master node”. Doesn’t exactly sound like that is a good thing lol. Going back to the Storage Management tab I see that the box is selected for it to be the master node.



  • @ravigon how about the values of igaPrimary (wonder why I wrote igaGroup …)?

    What is the ID in “Storage Management” -> “All Storage Nodes” -> your storage node (normally “DefaultMember”) -> “Storage Group”? And are the other settings there correct?
    Could you also check the Image Size log in “Fog Configuration” -> “Log Viewer” if there are any errors?



  • @tom-elliott Thanks Tom, agreed it is a nice feature and if I can’t get it to work it will not deter me from continuing my deployment of FOG. I am still in the beginning stages and have a lot to learn. So far it shows great potential and has already blown my mind on the speed difference compared to using our old Norton Ghost setup.



  • Ok so I captured a new image this morning and no change, still shows 0.00 iB. Where can I find the imageGroupAssoc table so I can check the value?

    Update: Installed MySQL Workbench and found the imageGroupAssoc table. igaStorageGroupID was already set to 1 for all three entries for the three images I have uploaded.


  • Senior Developer

    I should add to this thread too, in that this size on server is a nice to have feature but should not impact any ability to actually image a device.



  • The Image Size Service seems to run every hour and check the image sizes (Fog 1.4.4):

    ...
    [10-18-17 9:21:51 am] * Starting Image Size Service.
    [10-18-17 9:21:51 am] * We are group ID: 1. We are group name: default
    [10-18-17 9:21:51 am] * We are node ID: 1. We are node name: DefaultMember
    [10-18-17 9:21:51 am] * Finding any images associated with this group as its primary group
    ...
    [10-18-17 10:21:51 am] * Starting Image Size Service.
    [10-18-17 10:21:51 am] * We are group ID: 1. We are group name: default
    [10-18-17 10:21:51 am] * We are node ID: 1. We are node name: DefaultMember
    [10-18-17 10:21:51 am] * Finding any images associated with this group as its primary group
    ...
    

    But we once had a problem that its was not displaying the size for one or two images. The solution was that in the table “imageGroupAssoc” the value of igaGroup (?) was not “1” (I think it was 0).
    After manually changing this value to 1 the next time the Image Size Service was running all of the images was showing the “Size on Server”. Dont’ know what caused this but we didn’t have this since then anymore.

    So I think it’s worth checking the imageGroupAssoc table in the database and storage settings in FOG.



  • I am using Version 1.4.4. That’s interesting, good to know that it only grabs that info during the initial upload, I assumed it would just query the folder size on the server. Yes I checked the /images directory and I had two folders in there that were created by the uploads and both were about 14GB in size.

    Edit: I’ll upload another image in the morning to see if the issue is still there after messing with it.


  • Moderator

    First what version of fog are you using?

    Second, those values are only added during the upload process. While this isn’t your case, if you import the images from another fog server these values won’t be set.

    Can you confirm that if you look in the /images directory that your 2 images are there. Both the parent folder and the data files.


Log in to reply
 

428
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.