PXE can't find correct bootfile size



  • Hi!
    Just got below error after installing a main fog server and a storage node. Both of these are located different geographic locations. I also installed the location plugin.
    NBP filesize is 0 Bytes
    PXE-E23: Client Received TFTP error from server



  • @george1421 Good News! I got it to work. I noticed that I got bunch of alert about some host is trying to access the tftpd and httpd service. It was the firewall. At the beginning, while I was setting up the node, I typed systemctl stop firewalld; while I should have typed systemstl disable firewalld since I rebooted once.


  • Moderator

    @msi said in PXE can't find correct bootfile size:

    192.168.134.230

    And on the above ip address in /tftboot directory you have the ipxe.efi file? If everything looks good then on the remote fog server we will need to setup tcpdump and grab a pcap file of the booting process because something is going wrong here. All of the bits appear to be in place.

    https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    If you have questions on the pcap file, upload it to a google drive and either post the link here or IM me and I will take a look at it. I need to go off-line for a few hours, but I will be back later tonight.



  • @george1421 Correct. pointing to 192.168.134.230


  • Moderator

    @msi So this is at the remote location and you have the dhcp server sending out dhcp option 66 for the remote site’s storage node, and you are trying to pxe boot a uefi system?



  • @george1421 Trying to PXE boot at the remote site. Below is the settings from /opt/fog/.fogsettings:

    Install time: Fri 06 Oct 2017 02:51:32 PM EDT

    ipaddress='192.168.134.230’
    copybackold='0’
    interface='bond0’
    submask=‘255.255.255.0’
    routeraddress=’‘
    plainrouter=’‘
    dnsaddress=’'
    username='fog’
    password='rqx9gmtivQyiLLA3sn70T0El1iXdr3V59kX/boTCgUs='
    osid='1’
    osname=‘Redhat’
    dodhcp=’‘
    bldhcp=’'
    dhcpd='dhcpd’
    blexports='1’
    installtype='S’
    snmysqluser='fogstorage’
    snmysqlpass='fs13096747298’
    snmysqlhost=‘192.168.1.230’
    installlang=‘0’
    storageLocation=’/images’
    fogupdateloaded=1
    docroot=’/var/www/html/‘
    webroot=’/fog/'
    caCreated=‘yes’
    startrange=’‘
    endrange=’'
    bootfilename='undionly.kpxe’
    packages=‘bc curl gcc gcc-c++ gzip httpd lftp m4 make mariadb mariadb-server mod_ssl net-tools nfs-utils php php-bcmath php-cli php-common php-fpm php-gd php-ldap php-mbstring php-mcrypt php-mysqlnd php-process tar tftp-server unzip vsftpd wget xinetd ‘
    noTftpBuild=’‘
    notpxedefaultfile=’‘
    sslpath=’/opt/fog/snapins/ssl/‘
    backupPath=’/home/‘
    php_ver=’‘
    php_verAdds=’‘
    sslprivkey=’/opt/fog/snapins/ssl//.srvprivate.key’


  • Moderator

    @msi Is this at the main site or the remote site?



  • @george1421 yes! option 67 is ipxe.efi. FYI: Main Fog server is a Hyper-V


  • Moderator

    Ok so since it references to NBP, you are booting a uefi system? What do you have configured for dhcp option 67? ipxe.efi?

    At this point it is still a pxe issue and not related to FOG or location plugins.


Log in to reply
 

520
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.