Hyper-V Generation 2 VMs Aren't Booting Into Network -



  • FOG Version: 1.5.0-RC-8.
    SVN Revision: 6080

    Hi all,
    We’re currently having a problem with our FOG server where we can’t boot Generation 2 VMs over the network. We’ve turned off secure boot, and strangely enough, it did work the other night when we wanted to upload a newly built image. Now, however, it doesn’t work, and we’re not entirely sure why. We’ve reviewed what has changed and the answer is nothing - we had to restore FOG from a Veeam Backup the other day as a similar thing happened, but no machine could boot from the network. It only appears to be effecting Generation 2 VMs in Hyper-V, rather than everything.
    We see the following message:

    0_1507212717495_1.PNG

    I wonder if this has something to do with DNSMasq somehow breaking? I know there was a major update for it the other day, but we haven’t run any updates. Is there anything we could check?
    Any help with this would be appreciated.



  • @george1421 Thanks, George.
    This turned out to be an issue with the dnsmasq update. We have now updated to the latest version (following a full removal of dnsmasq), and had to edit the /etc/dnsmasq.conf file to include the DHCP range again.


  • Moderator

    @robtitian16 Tutorial most appropriately names: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    Post the pcap to a google drive/dropbox/etc and then share the link, either in a forum or IM me the link and that will tell us what is going on. It really helps to have the fog server, dhcp server, and pxe booting client on the same vlan to see the entire conversation. If that’s not possible, you can use wireshark on a notebook on the same vlan as the pxe target computer to capture at least the dhcp process. That is where the process is failing.



  • @george1421 Even after updating I still have the same thing, despite maintaining the exact same settings as before, and it is now affecting the hardware also, unfortunately.
    When attempting to boot from the network in either UEFI or Legacy mode, I see the following:

    0_1507545795430_05f3f08c-c667-4058-8a4f-560873bb878c-image.png Auto-Select:
    Boot BIOS PXE
    PCE-E78: could not locate boot server



  • @robtitian16

    I believe I’ve seen this when I’ve forgotten to disable Secure Boot in the Hyper-V VM definition.

    Jim



  • @george1421 Ah, that could be it… it’s showing as 2.68. I’ll try updating it and see how it goes.


  • Moderator

    On your fog server, can you open a command prompt and key in sudo dnsmasq -v to ensure its 2.76 or later?


Log in to reply
 

399
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.