iPXE Boot with iMAC Late 2013



  • Hi there,

    i am trying to boot an iMac late 2013 to my Fog Project Server using iPXE.
    I was able to boot my MacMini (2009) with iPXE. Capturing an Image was not a problem.
    Now, with the iMac i got the Error message :

    Waiting for link-up on net0................... Down (http://ipxe.org/38086193) 
    

    I tried out all .efi files that came with Fog Project installation (snponly.efi, intel.efi, realtek,efi etc.) every file was the same error.

    What can i do to get the iMac working like the MacMini ?


  • Developer

    Added to the list in the other thread so we don’t loose track of this here.


  • Developer

    @P-Schnoeckel It’s nothing you’re doing wrong here. Most probably you see the very same issue that numerous people have run into after installing Mac OS X Sierra on their machines. It’s got to do with a newer EFI firmware and most probably how it initializes the NIC.
    Follow this: https://forums.fogproject.org/topic/10615/ipxe-booting-possibly-broken-on-os-x-sierra-update (all the other threads from our forum and the iPXE forum are linked)

    If you are really keen to get this solved you might send me one of your machines (even better if you could send two - one where Sierra has not been installed yet). Just saying that because from your name it kind of sounds as you might be located in Germany, just as I am.

    We have been trying to remotely debug this for weeks and weeks and it’s just too hard not having the machine at hand. I am still keen to get into that again if someone is offering to lend me that hardware for a while…


 

446
Online

8.4k
Users

12.5k
Topics

117.7k
Posts