Snapin History Time Issue



  • Server: v1.5.0 RC9
    OS: CentOS7

    Client: 0.11.12
    OS: Windows 7 Pro x64

    Description:
    When scheduling a Snapin, the local time is used to indicate when the Snapin was Scheduled (see last line in screenshot below).

    0_1506608954212_f15d2f42-6d58-4564-94f2-446269869f9a-image.png

    Then, after the FOG Service on the PC communicates with the FOG Server, the times appear to change to GMT times (see last line in screenshot below).

    0_1506609054445_a858ab0f-7052-4dd3-8867-27fe40f5bd48-image.png

    Subsequent timestamps continue in GMT (again, last line below).

    0_1506609451103_cd661d6d-b1f6-4d4d-9a47-fd0aa0015f9a-image.png

    Jim



  • @tom-elliott

    Tom,

    Sorry about the delay, but I wanted to see more data before responding.

    The time zone change resolved a big part of the problem. All the times are now making more sense. I’m guessing the log store UTC because after changing the timezone setting, all Snapin Histories are as they should be - no time shifts.

    I can only suppose that to have the times appear as they did originally, the initial time stamps may have been coming from the client. I would suggest this isn’t a good idea since PCs are notoriously out of sync, but these days with SNTP, not so much. One would think it would be desirable to use all time stamps from the server.

    So… Thanks very much for pointing that out to me. I once knew timezone was a setting but seem to have forgotten…

    To be thorough, I do want to point out something, just to be sure that what I’m seeing is by design.

    Attached is a screenshot of the snapin history after a deployment for a machine.

    0_1507741140553_d0a33bc5-87b8-455b-bb7d-f18054867b0e-image.png

    Please note that there are only 5 Start Times for all 17 Snapins. It seems that the start time is only recorded for the first Snapin in a series of snapins executed in one pass of the FOG Service. Given the current report, one can determine the actual start time of a particular Snapin by doing the math (Add the previous snapin’s duration to the posted start time for the task). One can also determine the duration of each individual snapin by subtracting the previous snapin’s duration from the posted snapin duration.

    Personally, I’d like to see the snapin start time be the start time for each snapin, not the start time of a group of snapins that just happen to run sequentially. Simialrly, I’d also like to see the duration as the duration of a single snapin, not a group.

    If the current approach is by design, then ok. I certainly can live with what we have.

    Thanks,

    Jim


  • Senior Developer

    Did changing the TimeZone setting in the FOG Settings help resolve this issue?


  • Senior Developer

    The timezone should be able to be set from FOG Configuration->FOG Settings->General->FOG TZ INFO (Or TZ INFO)

    I’m guessing your’s is set to UTC at the moment. This likely won’t fix the previous times, but should make things relevant to your real timezone moving forward.



  • @tom-elliott

    I didn’t say I could do simple math, but I’m assuming it’s in 24 hr format the whole time and the Queue time is correct in local time. I create the Snapin task at 10:27 this morning, EDT (GMT-4). Add 4 hours to 10:30-ish and you get 14:30-ish times, GMT times. I’m still thinking the log shows local time when Queued, until the PC Checks in, then it switches to GMT for Checkin, InProgress and Complete times.

    But I certainly differ to whatever you think the problem is.

    Jim


  • Senior Developer

    You’re 12 hours from GMT?

    It looks like it’s switching between 24 and 12 hour time formats, not a TimeZone issue.


Log in to reply
 

492
Online

39192
Users

10844
Topics

103205
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.