HostnameChanger Unknown Return Code: 9560



  • Hi,

    I am currently Running Version 1.4.4. I am looking for some help in trying to resolve the HostnameChanger Unknown Return Code: 9560 error, how is the resolved?

    I am using the fields below
    FOG_AD_DEFAULT_DOMAINNAME
    FOG_AD_DEFAULT_USER


    --------------------------------HostnameChanger-------------------------------

    9/21/2017 11:31 AM Client-Info Client Version: 0.11.12
    9/21/2017 11:31 AM Client-Info Client OS: Windows
    9/21/2017 11:31 AM Client-Info Server Version: 1.4.4
    9/21/2017 11:31 AM Middleware::Response Success
    9/21/2017 11:31 AM HostnameChanger Checking Hostname
    9/21/2017 11:31 AM HostnameChanger Hostname is correct
    9/21/2017 11:31 AM HostnameChanger Attempting to join domain
    9/21/2017 11:31 AM HostnameChanger Unknown Return Code: 9560



  • @sebastian-roth It’s working now.


  • Developer

    @The-Dealman Yes that could be the issue. Do you still see the error or do you get a different error now after changing the domain name setting?



  • I think I see where the issue is for me. I have created groups and associated the devices to groups, so the clients pull the settings like Active directory from the groups. In the domain name field I put DC=internal,DC=domain,DC=net when it should be internal.domain.net right?


  • Developer

    @the-dealman said in HostnameChanger Unknown Return Code: 9560:

    9560

    Hmm that’s interesting. On a MS website it says:

    Error code: 9560
    DNS name contains an invalid character

    So what hostname are you trying to set? Maybe you’re using some language specific characters? Or possibly you copy&pasted that hostname from somewhere and there is something like a space at the beginning or end of the hostname in the FOG web UI set.


 

444
Online

41.7k
Users

12.2k
Topics

115.1k
Posts