Windows 10 Death Loop/Reboot



  • Server
    • FOG Version: 1.4.4
    • OS: Kubuntu
    Client
    • Service Version: 11.12
    • OS: Windows 10

    I’m trying to upload an image to my FOG server with Windows 10 and then sysprep with my answer file. After uploading to the FOG Server and deploying to a machine my computer is stuck in a loop/reboot. I uploaded the same image to Acronis Snap Deploy and it works perfectly fine. Not sure why FOG puts Windows in a loop. Any ideas?

    Description

  • Moderator

    @msaglioc99 What happens if you turn off force reboot for AD join?

    It’s possible it tries to join/change name, fails for some reason, forcefully reboots, and thus gets stuck in a loop.



  • Okay so the image I created with sysprep seems to work with the FOG Client Service but if I use that same image and tell it to join to the domain after the task has been complete it gets stuck in the reboot loop. Even after disconnecting it from the network it get’s stuck in this loop. I’m assuming this loop has something to do with the FOG Service and sysprep as this seems to be the common denominator. I have already followed the Wiki Instructions and disable the FOG Service and placed the .cmd file to start the service back up. Any ideas? Thanks for all your help!



  • Awesome ! I’ll have to try moving the XML file Monday as of now the image I uploaded with disabling the FOG service and creating the cmd script as found in the Wiki worked. So if I deploy to it using FOG it works fine. The only way it gets stuck in a reboot loop now is if I tell it to join to the domain after the task has been complete in the AD settings. If this is checked it gets stuck in the loop. There’s definitely some kind of conflict between FOG and Sysprep when booting the machine up.


  • Moderator

    @msaglioc99 I’ve been working on 1703 in my home lab and I’ve run into the issue where windows can’t install correctly after sysprep.

    After some intense debugging there are a few things that I came across.

    1. I have to place the unattend.xml file in c:\windows\panther if I placed it in the traditional place I’ve used since, forever c:\windows\system32\sysprep I was getting an error that windows couldn’t install because it couldn’t find the defined unattend.xml file. As soon as I change the location to c:\windows\panther and updated my sysprep command that part worked.
    2. For my unattend.xml file I decided to use the online generator here: http://windowsafg.no-ip.org/ I wanted to use this site to generate the unattend.xml script because I wanted a clean unattend.xml file and not rely on the one I’ve used for imaging for years. The unattend.xml downloaded from the online generator caused another error in that the product key defined by the generator was not liked by OOBE for Win10 1703. I removed the product key from the unattend.xml that came from the online generator and then it worked.

    Once the above fixes where implemented the sysprep and reboot on the reference system worked correctly. I’m currently in the process of rebuilding the reference image completely again with MDT to start with a clean build again to test the next part (capturing and deploying with FOG). To see if I can generate the error in this and other threads with not being able to capture and deploy the image correctly.



  • Okay I’ll do this Monday morning. Thx!


  • Moderator

    @msaglioc99 Ok, on this computer that is rebooting - when you’re at work - let it reboot a couple more times and then disconnect it’s network cable completely - let it do it’s thing for a while longer after this, it should stop rebooting. Then I need you to get a copy of the C:\fog.log file (use a thumb drive) and post the last 1,000 or so lines from it to here. It should tell us exactly what is happening and should lead us to an answer.



  • I’ve followed those instructions, disabled the service and placed the .cmd txt file in the folder stated.


  • Moderator

    @msaglioc99 Read through this for sysprep information while using the fog client: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep



  • I’m not in the office right now I’ll be back Monday but just to keep you guys updated since you’ve been so helpful. There’s nothing Non-Standard about the computer. It’s just a regular Dell Optiplex 7040. I’ve bern able to successfuly deploy images in the past that weren’t Syspreped but I’m trying to upload one that is. So before I left I was reading an article on here that if you’re sysprepping a machine you have to disable the FOG client at start up and then place a .cmd script in a folder under C > System so I did this and was able to successfully upload and deploy an image to a machine. The only isssue I’m having now is if I deploy an image and i tell it to join to the domain using the AD credentials after the task it gets stuck in the “loop” reboot and won’t stop resetting. So there’s defiantly something I’m still doing wrong… I only have this down half right with the Sysprep image lol. Any ideas ? (I know this is a lot to take in please let me know if something is confusing or you don’t understand, and thanks for all your help!)


  • Moderator

    @msaglioc99 What make/model is the machine? Anything non-standard about the hardware? What type of disk is in the machine?


Log in to reply
 

460
Online

38968
Users

10709
Topics

101631
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.