1.5.0 RC9 - Scheduled tasks view "disables" the web UI



  • Server
    • FOG Version: 1.5.0-RC-9
    • OS: CentOS7
    Client
    • Service Version:
    • OS: Windows 10
    Description

    Since RC9 when I go to the tasks menu and want to open the scheduled tasks, the Web-Frontend stops working.
    No more page opens, even after waiting for a very long time no reaction, reopening the web UI in a new tab doesnt change anything, no fog page loads.

    Deleting Cookies and Clearing Cache helps, login is possible again, as soon as I open scheduled tasks the same thing happens again.

    Problem with my server? Or with the RC?



  • No, was the first time I tried it.

    And according to the mysql thing there should only be 3 active scheduled tasks?

    I just ran the mysql cleanup commands from the fog-wiki … problem remains.


  • Senior Developer

    Do you do a lot of scheduled tasks? It sounds almost as if there’s a lot of delayed/cron jobs in the queue, based on what I’m hearing.



  • Just checked: Yes, all the other menu points in the tasks menu open correctly.


  • Senior Developer

    @taspharel This only happens on scheduled tasks?



  • Okay, here we go.

    Doing this first thing in the morning yields:

    MariaDB [fog]> SELECT * FROM scheduledTasks\G
    *************************** 1. row ***************************
    stID: 1
    stName: Deploy Task
    stDesc:
    stType: C
    stTaskTypeID: 1
    stMinute: 50
    stHour: 16
    stDOM: 13
    stMonth: 9
    stDOW:
    stIsGroup:
    stGroupHostID: 2
    stImageID: 0
    stShutDown:
    stOther1:
    stOther2: -1
    stOther3: fogadmin
    stOther4: 1
    stOther5:
    stDateTime: 0
    stActive: 1
    *************************** 2. row ***************************
    stID: 2
    stName: Hardware Inventory Task
    stDesc:
    stType: C
    stTaskTypeID: 10
    stMinute: 10
    stHour: 10
    stDOM: 1
    stMonth: 11
    stDOW: 0
    stIsGroup:
    stGroupHostID: 82
    stImageID: 0
    stShutDown:
    stOther1:
    stOther2: -1
    stOther3: fogadmin
    stOther4:
    stOther5:
    stDateTime: 0
    stActive: 1
    2 rows in set (0.00 sec)

    After that I scheduled a task, went to tasks view and waited for the freeze, after it shows the additional task:

    *************************** 3. row ***************************
    stID: 3
    stName: Memtest86+ Task
    stDesc:
    stType: C
    stTaskTypeID: 4
    stMinute: 1
    stHour: 1
    stDOM: 1
    stMonth: 1
    stDOW: 1
    stIsGroup:
    stGroupHostID: 80
    stImageID: 0
    stShutDown:
    stOther1:
    stOther2: -1
    stOther3: fogadmin
    stOther4:
    stOther5:
    stDateTime: 0
    stActive: 1
    3 rows in set (0.00 sec)


  • Developer

    @Taspharel Hmmm, nothing in the error logs anymore?! Well then we need to see what you have in the database. Open a terminal window on your FOG server (find the password in /var/www/html/fog/lib/fog/config.class.php):

    shell> mysql -u root -p
    Enter password:
    Welcome to...
    ...
    mysql> use fog;
    mysql> SELECT * FROM scheduledTasks\G
    ...
    mysql> quit
    

    Post what you see here in the forum either as text or picture.



  • I edited the php.ini file as suggested here: https://forums.fogproject.org/topic/6800/php-fatal-error-allowed-memory-size-of-134217728-bytes-exhausted-fog-1-2-0-missing-fog_memory_limit/2
    in order to get rid of the above error.

    Now that error doesnt appear anymore in the error_log

    But nothing else does either and the web gui still doesnt work :-/



  • I just noticed the server time is off by an hour, maybe that plays into this?

    Edit: Naw … Same problem, trying to check the scheduled tasks freezes the web GUI



  • I get - before I start the scheduled task even, this error:

    [Fri Sep 15 07:38:47.258945 2017] [:error] [pid 4691] [client 192.168.43.88:34096] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32768 bytes) in /var/www/html/fog/lib/fog/fogcontroller.class.php on line 261, referer: http://fog.lfdw.local/fog/management/?node=host&sub=edit&id=82

    After I start a cron job the web gui says it saves fine, but I get the same above error message in /var/log/httpd/error_log.

    Then when checking in tasks -> scheduled tasks that stops the web gui from working but in the log file nothing else happens.


  • Moderator

    When you open the scheduled tasks view the web gui stops. When that happens please inspect the apache error log via the linux console on the fog server. The apache error log is located in /var/log/http directory. Just tail that file and post the error here, please.


Log in to reply
 

403
Online

38953
Users

10706
Topics

101570
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.