Problems capturing Windows 10 image



  • Server
    • FOG Version: 1.3.4
    • OS: Windows 10
    Client
    • Service Version: ?
    • OS: Windows 10
    Description


  • Thanks everyone, I upgraded to the newest version of Fog, and had to do the following and now it works:

    Windows 8.0, 8.1, and 10 (and most likely future Windows versions) have a feature called “Fast Startup”. This feature basically sets windows so that a hibernation occurs whenever the system is shutting down. This enables Windows to startup much faster than in past Windows versions. Because this feature is on by default, the windows OS partition has a hibernation file which prevents mounting and imaging via FOG, and also marks the OS partition’s “Dirty Bit” to ON. Even when hibernation and fast startup is disabled, the hibernation file remains and the “Dirty Bit” remains ON and these things causes problems. There are a few ways to fix/get around this.

    Way 1 (clean method)
    Disable: “Turn on fast startup”, located here: Control Panel (Classic View) -> Power Options -> Choose what the power button does -> Change Settings that are currently unavailable -> “Turn On Fast Startup & Hibernate”

    Both of those settings should be turned off for use with FOG. They may be turned on at a later time via GPO or snapins.

    Shutdown and then boot the system.

    Then run this command from an elevated command prompt to disable hibernation and remove the hibernation file:

    powercfg.exe /H off

    Now you can shut down and reboot once or twice, and then capture your image via FOG.


  • Developer

    @michaeloberg While upgrading to 1.4.4 at least is definitely wise you also want to read through this I reckon: https://wiki.fogproject.org/wiki/index.php?title=Windows_Dirty_Bit


  • Moderator

    @michaeloberg Here please follow this process.

    sudo -i
    apt-get update
    apt-get install git
    git clone https://github.com/FOGProject/fogproject.git /opt/fogproject
    git checkout master
    cd /opt/fogproject/bin
    ./installfog.sh
    


  • OK found the article, but when I do step 1: sudo apt-get update && apt-get install git
    I get the attached error messages (at bottom). Not a Linux expert so bear with me, and thanks for the help!0_1504728202821_Fog error 2.JPG


  • Senior Developer

    @michaeloberg yep all over the place. Look on wiki for Upgrade to trunk. To go to the rc you use dev-branch, stable use master on the git checkout.



  • Is there an upgrade path or set of instructions I could get on how to do this?


  • Senior Developer

    I’d recommend updating to 1.4.4 or even the rc series first.



  • We are attempting to start a roll-out of Windows 10 machines, however when we create a capture task, restart and PXE boot we get the attached error message. Any help would be greatly appreciated!

    0_1504726748659_fog error.JPG


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.