Laptop with USB Ethernet RTL8153 get Station IP, then exit



  • I got a Fog server configured according to the instructions:
    https://wiki.fogproject.org/wiki/index.php?title=Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server

    This works with virtual images and computers with regular network cards, however, I got an Asus Ultralight Laptop which have to use a provided USB network adapter. When trying to start this system with PXE boot, it does get its “Station IP” from the DHCP server, but unlike the other machines, no gateway or other IP addresses are listed, it exit and start regular boot from its internal drive.

    I am thus assuming it is something wrong with the setup. Configurations:
    #/etc/dnsmasq.d/ltsp.conf
    port 0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,192.168.0.2
    dhcp-no-override
    pxe-prompt=“F8 for boot menu”, 3
    pxe-service=X86PC, “Boot from network”, undionly # Might machine not identify as X86PC due to USB network card?
    dhcp-range=192.168.0.2,proxy
    #end of /etc/dnsmaskq.d/ltsp.conf

    Any ideas?


  • Moderator

    @kandresen Which part was it? Just for those that might find the thread in the future.



  • @george1421
    That was it! The Asus laptop finally got registered with the Fog server!

    Thanks a lot for the help!


  • Moderator

    @kandresen Your post you are missing the pxe service settings.

    pxe-prompt="Booting FOG Client", 1
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    

    IF that doesn’t work then we may have to override your real dhcp server which is potentially sending out a boot file. We may have to do this.

    pxe-prompt="Booting FOG Client", 1
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe, 192.168.0.2
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi, 192.168.0.2
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi, 192.168.0.2
    

    If the above solution doesn’t work for you then we will need to capture the communication going on between the client computer, dhcp server and the fog server. We’ll go down that path if the above sections don’t work.


  • Moderator

    @kandresen Secure boot is a Microsoft thing. Short answer is secure boot is not available for FOG or most non-MS softwares.

    If you are using Dells you can re-enable secure boot & TPM using CCTK in the setupcomplete.cmd file at the end of Windows Setup.



  • @george1421
    By the way, the laptop in question is an about 3 years old Asus UX302LA
    It got secure boot disabled, at least now while testing. Can secure boot be used with PXE?



  • That did unfortunately not work. I did use your configuration, then simply restart the server before my restart.

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,,192.168.0.2
    dhcp-no-override
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,192.168.0.2
    dhcp-boot=net:UEFI,ipxe.efi,,192.168.0.2
    dhcp-boot=net:UEFI64,ipxe.efi,,192.168.0.2
    dhcp-range=192.168.0.2,proxy
    

    #end of /etc/dnsmaskq.d/ltsp.conf


  • Moderator

    @kandresen OK then if you are using 2.76+ then please use my configuration file. It will automatically switch between the flavors of firmware. That config confirm works. We may have to tweak it if you have an abnormal network (where your dhcp server is telling one bit of information and we need to override it with dnsmasq).



  • The dnsmasq version I use is the default deb package from Debian (9.1) Stretch:
    dnsmasq 2.76-5
    dnsmasq-base 2.76-5+b1

    I have just reconfigured and rebooted my server, and hopefully this is the reason! I know my system is UEFI, not regular BIOS.


  • Moderator

    Your ltsp.conf file looks ok.

    Just for the sake of argument, could you try my ltsp.conf from this post: https://forums.fogproject.org/topic/8725/compiling-dnsmasq-2-76-if-you-need-uefi-support/6

    Just replace the <fog_server_IP> with the IP address of your fog server and then restart dnsmasq.

    [EDIT:] But before you try it, can you tell me what version of dnsmasq you have installed. The older ones than 2.76 need a few fixes plus they don't support uefi and bios images auto select at all

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    

Log in to reply
 

459
Online

39010
Users

10725
Topics

101896
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.