• Server
    • FOG Version: 1.4.4
    • OS: debian 8
    Client
    • Service Version:
    • OS: Windows 7 pro 64

    Hello, I have a problem with the upload of an image, everything goes well but in the end at the time of writing / moving the image I get this error message :

    [client 192.168.0.24:55364] PHP Warning: ftp_put(/images/dev/782bcb7efba1): failed to open stream: No such file or directory in /var/www/html/fog/lib/fog/fogftp.class.php on line 708

    PHP Warning: ftp_put(/images/dev/782bcb7efba1): failed to open stream: No such file or directory in /var/www/html/fog/lib/fog/fogftp.class.php on line 708

    0_1504185081005_img.jpg

    I have check permission of /home/fog/images and it’s seem to be ok, here the return of : ls -hail /home/fog/images

    15335426 drwxrwxrwx 3 fog root 4,0K août 31 13:47 .
    15335425 drwxrwxrwx 3 fog root 4,0K août 31 10:35 …
    15335427 drwxrwxrwx 3 fog root 4,0K août 31 11:21 dev
    15335429 -rwxrwxrwx 1 fog root 0 août 31 10:35 .mntcheck

    I tried with a ftp client, to see if the problem came from VSFTP but everything works idem for TFTP , here my vsftpd.conf :

    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES
    seccomp_sandbox=NO

    and tftp in /etc/default/

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root”
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS=":69"
    TFTP_OPTIONS="-4 -s"

    I have already change (twice) password for fog user and make the change in “Fog Settings” and “Storange Managment” but the issue remain.

    Did you have a idea ? thank !


  • @sebastian-roth and all Many thanks, it’s work , for my excuse i thinked the ftp path was beginned from the root profile (/home/fog) not at the complete path (/)

    Regards

    i marks this topic as solved


  • I look at it and come back to you thank you

  • Moderator

    @jeremyvdv said in Issue:

    j’ai fais la commande sur / images car c’est un point de montage qui pointe vers / volumes1 / images2

    Translated: “I made the command on / images because it is a mount point that points to / volumes1 / images2”

    What do you mean by that?!

    From what I see you have a huge mess with the FOG service account. Follow this guide and make it use fogproject in every place: https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password

    As well run chown -R fogproject:fogproject /images /volumes1/images2!


  • j’ai fais la commande sur / images car c’est un point de montage qui pointe vers / volumes1 / images2

    f8d353c4-0d78-48ed-b237-83dd01f9882b-image.png

  • Moderator

    @jeremyvdv Please go through this trouble shooting guide to make sure you have all the settings right.

    I am in version 1.5.7 and I try to capture a windows7.

    Then you shouldn’t have the user named fog (old pre 1.5.7 installs) but rather fogproject. Please run ls -alR /volume1/images2 and post the output here.


  • I finished parking the client’s lease … and now my pc is starting up again and again.

    545371d4-8c02-4617-8872-310317161346-image.png

    a4d5b760-b5f4-4717-90ba-ea517e1659dc-image.png

    help me 😕

    thanks


  • Hello

    so I changed the workstation and here is the new error message.

    c7c4b233-0356-4d98-9d33-2d0ded11f974-image.png


  • I tried this setting but sabs succes

    I will test again

  • Moderator

    @jeremyvdv In the pictures you posted we see that Image Path is set to /volume1/images2 while FTP Path is set to /images. Change FTP Path to the same you have in Image Path and the error should go away.


  • it’s correct for you:

    f32d9f70-95af-4fcc-add1-097b57b389d4-image.png

    38067d18-2358-4d21-9478-adffa33380d2-image.png

    knowing that my images are well created in / volumes1 / images2 / dev


  • I still have this problem and I start to despair 😕

    93ea2014-0bf9-4e40-98f3-78db8033ffbd-image.png


  • I am in version 1.5.7 and I try to capture a windows7.

    My pc goes to the end of the capture without error message. But the spot on the web fog does not stop.

    And error during the download / bin / upload.

    Thanks for your help

  • Moderator

    @jeremyvdv said in Issue:

    I have exactly the same problem of writing by Manuel but I do not understand the solution.

    Thank you for your help

    Please start with a new thread. Also include the version of FOG you are using, what host OS the fog server is running, and a screen shot of the error message. The developers may ask for additional information once they review what you have posted.


  • I have exactly the same problem of writing by Manuel but I do not understand the solution.

    Thank you for your help


  • @sebastian-roth and all Many thanks, it’s work , for my excuse i thinked the ftp path was beginned from the root profile (/home/fog) not at the complete path (/)

    Regards

    i marks this topic as solved

  • Moderator

    @Manuel Something has been tampered with here. The apache/PHP error says path ... /images/dev/782bcb7efba1 ... while .fogsetting has storageLocation='/home/fog/images' set. Please check in the web UI: Storage Management -> edit DefaultMember -> “Image path” and “FTP path”…


  • same issue with another server :
    HP Dl 360e Gen8 on debian 8 raid1 with mdadm ext4 fs

    fresh install (this afternoon)

    error log

    [Thu Aug 31 17:59:32.625387 2017] [:error] [pid 39238] [client 192.168.0.24:52958] PHP Warning: ftp_put(/images/dev/782bcb7efba1): failed to open stream: No such file or directory in /var/www/fog/lib/fog/fogftp.class.php on line 708
    [Thu Aug 31 17:59:32.625287 2017] [:error] [pid 39238] [client 192.168.0.24:52958] PHP Warning: ftp_rename(): RNFR command failed. in /var/www/fog/lib/fog/fogftp.class.php on line 769 
    

    .fogsetting

    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Find more information about this file in the FOG Project wiki:
    ##     https://wiki.fogproject.org/wiki/index.php?title=.fogsettings
    ## Version: 1.4.4
    ## Install time: jeu. 31 août 2017 17:18:31 CEST
    ipaddress='192.168.0.246'
    copybackold='0'
    interface='eth0'
    submask='255.255.240.0'
    routeraddress='192.168.1.254'
    plainrouter='192.168.1.254'
    dnsaddress='8.8.8.8'
    username='fog'
    password='*****'
    osid='2'
    osname='Debian'
    dodhcp='N'
    bldhcp='0'
    dhcpd=''
    blexports='1'
    installtype='N'
    snmysqluser='root'
    snmysqlpass=''
    snmysqlhost='localhost'
    installlang='0'
    storageLocation='/home/fog/images'
    fogupdateloaded=1
    docroot='/var/www/'
    webroot='/fog/'
    caCreated='yes'
    startrange=''
    endrange=''
    bootfilename='undionly.kpxe'
    packages='apache2 bc build-essential cpp curl g++ gawk gcc gzip htmldoc lftp libapache2-mod-php5 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php5 php5-cli php5-curl php5-fpm php5-gd php5-json php5-mcrypt php5-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g '
    noTftpBuild=''
    notpxedefaultfile=''
    sslpath='/opt/fog/snapins/ssl/'
    backupPath='/home/'
    php_ver='5'
    php_verAdds='-5.6'
    sslprivkey='/opt/fog/snapins/ssl//.srvprivate.key'
    ## End of FOG Settings
    

    return of ls -hail /home/fog/images

    total 12K
    11665413 drwxrwxrwx 3 fog root 4,0K août  31 17:32 .
    11665409 drwxrwxrwx 3 fog root 4,0K août  31 17:31 ..
    11665414 drwxrwxrwx 3 fog root 4,0K août  31 17:45 dev
    11665415 -rwxrwxrwx 1 fog root    0 août  31 17:32 .mntcheck
    

    tftp-hpa

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS=":69"
    TFTP_OPTIONS="-4 -s"
    

    vsftpd.conf

    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES
    seccomp_sandbox=NO
    idle_session_timeout=60000
    data_connection_timeout=12000
    

    dhcpd.conf

    # Sample configuration file for ISC dhcpd for Debian
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.0.246;
    
    subnet 192.168.0.0 netmask 255.255.0.0 {
            option domain-name-servers 192.168.1.254;
            option domain-name "edu.psallette.fr";
            option routers 192.168.1.254;
            option broadcast-address 192.168.0.255;
            filename "undionly.kpxe";
            default-lease-time 600;
            max-lease-time 7200;
            option tftp-server-name "192.168.0.246";
    	option bootfile-name "undionly.kpxe";
    	next-server 192.168.0.246;
    	deny unknown-clients;
    }
    
  • Moderator

    @manuel Then your the fog installer didn’t complete correctly. I would suggest that you reinstall fog. I will ask you the questions again since that .fogsettings file doesn’t exist.

    [edit] before you do that look in the same directory as the fog installer. There is an error log directory. See if there is anything important in the error logs.


  • @george1421 said in Issue:

    ls -la /opt/fog

    I know and the result is the same no .fogsetting

  • Moderator

    @manuel Sorry for the slow response.

    To view hidden files you need to issue the following command ls -la /opt/fog

    If you don’t have the .fogsettings file then the fog installer did not complete the first time you ran it.

359
Online

9.5k
Users

15.9k
Topics

147.6k
Posts