Possible GUI Problems In Latest



  • Server
    • FOG Version: v1.5.0 RC-8 v16 Working Branch Updated 10am EDT
    • OS: CEntOS 7
    Description

    Was running a previous version of v1.5.0 RC-8 and found some GUI problems. Upgraded to latest, rebooted, problems persisted:

    • Cannot Delete Snapins from a Host. Check boxes, hit delete, GUI posts the host was updated but refreshing page (F5 or exiting browser and reconnecting or by logging out and back in) shows all Snapins remain associated with the Host. Adding new Snapins works.

    • Display of Protection State in the full Images list displays correctly - those images that are protected show the lock closed, those that aren’t protected show the lock open. In the general page for the image, the Protected checkbox always shows as unchecked, regardless of the actual state. Checking the box and updating causes Image Updated! message but refreshing the page (as above) shows the box to be unchecked. The All Images list show the Protection State exactly as it was prior to going into the General Tab and making the change. I tried changing the Protected box on Images that were protected and images that weren’t and no change could be seen on either the All Images List or in the General tab for the image.

    These may be a database problem on my system or they’re GUI problems with FOG, but I don’t see other database consistency issues. I’ve made no changes to my system and have been busy testing Snapins and building images with no problems. I don’t know when I last tried to remove a Snapin association to a Host or to protect or unprotect an image but it could have been 2 weeks ago or more.

    Please advise.

    Jim



  • @tom-elliott

    Thanks Tom. The two fixes worked, so the image protection and manual add of a host are working.

    We still cannot delete any snapins associated with any host, so this isn’t Solved for us. Should I post this issue separately in a different section of the forum? Can you give us any idea what to look at?

    Thanks for your help,

    Jim



  • @jim-graczyk or you can import the host(s) from a csv file. The structure is:

    "00:11:22:33:44:55","name for the host"
    .
    .
    .
    

    I’m not sure if that’s a comma or a semicolon (or maybe both working)


  • Senior Developer

    I could not replicate the problem for deleting snapins. I was able to replicate and fix the Protection checkbox on images. I also fixed the cannot manually add from another bug report.

    All in working.



  • Update - was able to add Host from PXE boot menu.

    Jim



    • Additional Possible Issue - Cannot manually add a Host to the system with Create New Host.

    Entered all required values, hit Add. Nothing happens. Apache error_log has the following line or similar for each click of the Add button:
    [Mon Aug 28 11:16:50.210637 2017] [:error] [pid 12409] [client 10.179.100.156:56393] PHP Fatal error: Call to a member function isValid() on null in /var/www/html/fog/lib/pages/hostmanagementpage.class.php on line 637, referer: http://fogserver/fog/management/index.php?node=host&sub=add

    There appears to be no Apache error_log entry for the other 2 possible GUI issues.

    Jim


Log in to reply
 

436
Online

38994
Users

10714
Topics

101705
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.