FOG Registration; Host not registered



  • Server
    • FOG Version: Running Version 1.5.0-RC-8
    • OS: Debian 9.1
    Description

    Hello,
    I am currently running into an issue with fog. I start fog via pxe with the commands:
    dhcp
    boot http://x.x.x.x/service/fog/ipxe.boot.php
    after doing so the pxe menu pops up and I can register a machine.
    This process works without any errors at all.
    In the fog webGUI I then choose a empty image and schedule an capture task for the newly registered machine.
    It shows up in the webGUI and it also has the right MAC Adress.
    Now I reboot the registered machine and start the pxe menu with the same commands again and now it says
    Host is not registered.
    I looked in this forum and tried everything I could find from fixing my mysql database to reinstalling to use different pcs.
    Hopefully someone can help me with this.


  • Developer

    @natsufiree Please let us know about the current state of this! Will mark this solved fairly soon as George’s suggestions should put you on the right track.


  • Developer

    @natsufiree Any news on this??



  • Temporary you can use some proxyDHCP software on a second computer. dnsmasq was mentioned for linux. For Windows you can use Serva and There are apps for android too like Servers Ultimate that contains it.


  • Moderator

    @natsufiree Here are the instructions for building a usb boot into FOG. https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    There is a sequence you must execute to image with usb.
    You must schedule a capture or deployment task before you usb boot your target computer or you will get an error about an invalid task type “Null”

    You can register a computer by usb booting and picking registration. But you must remember to when capturing or deploying images to schedule them on the fog web gui first then usb boot the target computer.


  • Moderator

    @natsufiree I wrote a tutorial on how to compile dnsmasq 2.76. If you need to support both bios (legacy mode) computers and uefi computers then you will need to use dnsmasq 2.76 or newer. Not all linux distributions have an updated version of dnsmasq. If your linux distribution does then the setup is pretty easy. Just use the ltsp.conf config file I have posted in the thread. Update the <fog_server_IP> directives with the IP address of your fog server and restart the dnsmasq service.

    If your linux distribution does not have version 2.76 or newer then you must follow the instructions in the tutorial on compiling your own version of dnsmasq. The instructions I created for ubuntu, but should work for debian.

    https://forums.fogproject.org/topic/8725/compiling-dnsmasq-2-76-if-you-need-uefi-support/6

    Once you have the current version of dnsmasq installed then update the config file and start the dnsmasq service.



  • @george1421 oh the dnsmasq option is probably what I am looking for. I would be grateful for an explanation of both options.


  • Moderator

    @natsufiree said in FOG Registration; Host not registered:

    I see a conflict in what you say. I think we may have a language translation problem. So we will go slow.

    First you say your router does not support dhcp

    my router does not support dhcp.

    Then you say it is

    I am using the router for dhcp ip addresses.

    OK I understand (I think) your router is your dhcp server but you can not change anything on your router. FOG does have an option to work with a dhcp server you can not modify. You can load dnsmasq on your fog server to supply the missing dhcp pxe boot options. This works very well and will not change your dhcp router at all. The dnsmasq service will just hear the dhcp request from the client and add in the pxe boot information.

    We do have another option to usb boot into fog, but you will loose some features of fog. This is an option when you can not pxe boot your computers at all.



  • @george1421 my router does not support dhcp. I am using the router for dhcp ip addresses. In the enviroment I want to use fog finally tho another server is distributing the dhcp services but I am not allowed to edit those. I used commands to boot with pxe because I don’t want it to my interfere with other packages in that network. All I am looking for is that it successfully does tasks.


  • Moderator

    @natsufiree OK, let me say you started wrong. But no worries we can get you pointed correctly again.

    Do you have a dhcp server on your network or are you using your router for dhcp ip address?

    If you are using your router for dhcp; does your router support optional dhcp settings like option 66 and option 67 or support pxe booting? If you don’t know can you tell me the model of your router?



  • @george1421 i got my ipxe iso from https://www.rom-o-matic.eu/ with the params cmd enabled.
    What is the right boot file?
    currently my network is a basic [serverpc -> router <-bootpc].
    Yes I am attempting to boot this system via pxe.
    I don’t have dhcp configured on my debian since the enviroment in which this should work can’t be configured with the internal dhcp coming with fog.


  • Moderator

    Ok lets start with your very fist picture.

    That is not a standard FOG ipxe boot.

    1. Where are you getting this iPXE ISO boot image from?
    2. ipxe.kern is not the right boot file.
    3. How do you have your network setup?
    4. Are you attempting to pxe boot this system?

    What do you have configured for dhcp options 66 {next-server} and dhcp options 67 {boot-file}?



  • alt text
    alt text
    alt text
    Here they are.


  • Developer

    @natsufiree Please post a picture of the client’s screen when it boots and says “iPXE initializing devices” and shows the MAC address. As well take a screenshot of the registered host’s settings on the web GUI and upload here in the forum.


 

403
Online

5.4k
Users

12.6k
Topics

118.9k
Posts