Fog Exit Windows 10



  • Hi we are currently trying to update our computers to Windows 10. We have successfully manged to upload and deploy the image to certain computers and have managed to get the host name and active directory joining working. The only issue have are having now is the Exit from fog to Windows as we have LAN as the first boot option. What is currently happening is when fog tries to exit to Windows we either get a flashing cursor or the no boot devices message. We have tried changing the exit method to all of the different options but still no joy. The exit works fine with all of the existing Windows 7 computers it is just since trying windows 10. We do not want to change the boot order as if we need to image computers we will have to go around changing this just to do that task. Has anyone else come across this before and how did you manage to get around this?

    Any help would be much appreciated.

    Thanks


  • Developer

    @dbrilliant Can’t see what your post has to do with the original indeed very old topic. We have enough room in our forums for everyone to open fresh specific topics and I ask you to do so. Tell us about your setup, FOG version, OS and so on…



  • I have a new batch of 10 Dell 3060 SFF desktop PCs with WIndows 10 64 bit. I disabled Secure boot, but if I try to keep UEFI/non-legacy and boot to my stand-alone fog server that’s not behind a firewall, after 3-4 seconds PXE times out to the Dell System Support memory checker and then gives me a few boot options and turns the PC off. If I turn off UEFI and enable Legacy mode Rom’s, I can PXE boot into FOG and upload/download images, however, they won’t work with Legacy mode disabled (corrupted image), and even if I turn it back on, it quits talking to the FOG server entirely. And also, the PC I was able to image, I re-enabled UEFI boot mode, and the boot failed into windows. Any thoughts… I’m checking the drive type as mentioned in an above post.



  • @george1421 We have Dell 3050’s with the default settting on RAID-ON, as opposed to AHCI. We migrated from a FOG server running 1.4.2 to one running 1.4.4, and now the Dell computers show just a blinking cursor in the upper left corner just after selecting the Local Boot option from the FOG menu. Was there a change between the 2 versions that affect this? The Dell computers were working in RAID-ON mode while booting to the 1.4.2 server.



  • Hi,

    i removed hdbios from refind.conf, additionally i had to set refind for the specific host, because the main option under fog settings didn’t had a effect after i set it to refind for efi, i still got chainload failed.

    After setting it for the specific host to refind the machine will try refind when booting from network but anyway all i see is:

    rEFInd - Initializind…

    Screenshot:

    Bild Text
    Machine will stick there forever…

    Nothing else is happening.
    What can i do?

    my refind.conf now only contains “internal” for the scanfor line.

    I need to get this work either for legacy and efi, how should my machine exit the fog menu when they are booted by network? By default i let the machines boot after 5 seconds from harddisk when no interaction appears in fog menu.

    This is now broken for the most of our systems.

    EDIT:

    Strange refind is working for an Intel NUC but not for an HP Probook 650 G2. Any ideas? I have a lot of Probook 650 G2’s and only some NUC’s.

    FYI: The Probook 650 G2 is has an Intel I219-LM the NUC has an Intel I219-V network card.
    I don’t know if my issue is maybe network card related.

    @george1421 @Wayne-Workman @tom-elliott

    Additional i found a bug, that was causing me to force specific host exit type settings because fog settings doesnt store the change:

    https://forums.fogproject.org/topic/11435/fog-rc12-settings-exit-types-legacy-efi-will-not-be-saved-after-change

    Regards X23


  • Moderator

    @x23piracy Let me see if I can explain it. I’ll explain the easy part first.

    As you know with FOG, it has 2 exit modes. One is for bios type computers and one is for uefi mode computers. These exit modes actually tell iPXE how to leave the PXE boot menu. They really don’t come into play for imaging at all. Once imaging starts then FOS takes over rebooting the system. So in our case we can only instruct iPXE how to react.

    So for bios systems they will only use the bios exit mode field. The same for uefi systems they will only use the uefi exit modes. Understand because of the way fog is setup, you can technically assign a uefi exit mode to the bios field. That would cause the system to not reboot correctly. So anyway to the point if you have a uefi system changing the bios exit modes for that host will not have any impact on the computers ability to reboot since it only looks at the uefi exit mode field.

    Now the second part. What that refind error is saying is that you have a parameter in the scanfor line of the refind.conf file that says if it can’t find any uefi boot loaders, to look for bios boot loader in the firmware. The CSMD support error basically means that your firmware doesn’t contain any legacy mode boot loaders. In Dell terms this means that you don’t have the legacy roms enabled in uefi mode (which is only provided for backwards compatibility). So to fix this (unfortunate with refind and the way its currently setup is either all or nothing, we can’t have system unique refind.conf files) 1. Remove the parameter in the scanfor line in refind.conf to tell it to not look for CSMD firmware. 2. Enable legacy roms support in the target computer’s uefi firmware.



  • Hi,

    i still have issues with the exit modes, when i try refind with efi enabled Computers or Notebooks its luck if they boot from hdd/ssd or not some work some not (chainload failed, press s… reboot in 10 seconds) if the system then reboot they try to boot from network again and the computer need to turned off/on so they can boot normally again.

    Thats really bad if i wake system remotely (for example with PDQ Deploy) some of them then are always in a boot loop.

    What can i do, how to solve this if one specific mode is not working for this or that system, figure it out for each what works and use the host specific settings sound like a time killer to me.

    I am in a mixed environment, older system still use legacy all the newer ones use efi with disabled secure boot.

    This is what i get when i try refind with a uefi enabled notebook while secure boot is disabled (HP Probook 650 G2):
    Bild Text

    For this device neither of the modes work: sanboot, exit, refind all fail. Even when i set the notebook to legacy, uefi (with or without secure boot)

    sanboot on efi enabled system loop into fog menu again
    exit will bring chainload failed
    refind brings the csm error (screenshot)

    Regards X23


  • Moderator

    @fog_rob Just for clarity on this issue, fog works perfectly well with uefi systems. You do need to send the right iPXE kernel to the target computer to boot into a FOG uefi iPXE menu. When you have a uefi system you must disable secure boot to allow non-microsoft systems to boot, sometimes turn on the uefi network stack (dells typ) and update dhcp option 67 to send ipxe.efi as the boot kernel name to the target computer. If you do that a uefi system will boot and image without issue. The only exception is typically Dells that will default the disk mode to raid-on. At the moment uefi linux can not boot with the disk controllers in raid-on mode, if you switch the disk mode to ahci then uefi works. This is a limitation we’ve only found so far with Dells and unsupported disk modes.



  • @sebastian-roth , was old FOG .25 and didn’t have UEFIcomputer then. Now with windows 10, it goes way faster to use FOG then our cloning system (SCCM). I posted my solution here explaining how I solved my problem until a better solution is found.

    thank you guys for your support, we all appreciate !!!



  • @george1421 Thank you for the reply George, but tried that and no go.

    I found a solution tho, I had to re install Windwos 10 but before, I removed all Secure boot key management Options and set the secure boot operation to Legacy support enable and secure boot disable

    Boot Option to legacy boot Only.

    it worked normally after that.

    so from now on, I will set all uefi comptuters that way before foging ;-)


  • Developer

    @fog_rob said in Fog Exit Windows 10:

    Hi, I juste upgrated to fog 1.4.4 and I’m having the exit of FOG problem too.

    Which version of FOG did you use before? Are you saying that it worked with the old version?


  • Moderator

    @fog_rob Just so we are clear here. BIOS and UEFI systems have their own exit mode. There are global settings and on per host exit modes. For bios the standard exit mode is SANBOOT, for UEFI systems the default exit mode should be rEFInd. Each firmware type will choose its own exit mode.



  • @sebastian-roth , Hi, I juste upgrated to fog 1.4.4 and I’m having the exit of FOG problem too. :(

    Windows 10 LTSB is installed on our computers and they all boot to network first. It boots out fine on older computer models ex: Dell Optiplex 755 but not on uefi computers ex: HP probook 450G3, on FOG exit, no matter what the host bios exit type is, it won’t boot but if I set the computer to boot from hard disk first it works.

    I looked here and there and didn’t find a solution yet.

    did you guys found something to solve this?



  • @sebastian-roth Correct. My Dell Optiplex 5040’s are in legacy mode. Never had luck with FOG and UEFI always got the “Chainloading” error message that is why they are in legacy mode. Thanks for your help.


  • Developer

    @ljedi said in Fog Exit Windows 10:

    I switched the HOST Bios Exit Type to GRUB and computer was able to boot into Windows. Thanks.

    Well then in your case I guess you installed windows in legacy BIOS mode but not UEFI mode… Seems this is solved for you then.

    But I still have the feeling that we have others here who installed in UEFI mode and have issues booting this way now.



  • @george1421 Correct. The boot order on the computer is IPXE first. If I take IPXE out of the boot order, Windows boots just fine.

    @Sebastian-Roth I switched the HOST Bios Exit Type to GRUB and computer was able to boot into Windows. Thanks.


  • Moderator

    @ljedi said in Fog Exit Windows 10:

    I have not yet created an image for this version yet. 1703 is a clean install and not an upgrade from 1607

    This confuses me a bit. Just so I understand what I think you said and didn’t say. You created a fresh install of 1703 that works. But when you add pxe booting first in the boot order, iPXE is not exiting correctly to boot windows? But when you have the hard drive first in the boot order the pc boots correctly??

    I just trying to understand the flow here. I want to see if I can duplicate that in our lab, I just need to know how you did what you did.



  • @george1421 I have not yet created an image for this version yet. 1703 is a clean install and not an upgrade from 1607.

    @Sebastian-Roth I will test with the different exit styles and get back with you soon.


  • Moderator

    @ljedi What hardware are you deploying to?

    Did you use single disk resizable?

    Did you upgrade windows to get to 1703 or did you install it from a newly created reference image?

    There has to be something in common here.


  • Developer

    @ljedi said in Fog Exit Windows 10:

    My environment is Windows 10 1703 in legacy mode

    I am still wondering if this is all the same issue or several different ones. Can you please try all the different exit style settings. So far I wasn’t able to replicate the issue and I really wonder why so many people seem to have an issue.


Locked
 

500
Online

5.4k
Users

12.6k
Topics

118.6k
Posts