Windows 10 1703 system error on boot



  • Server
    • FOG Version: 1.4.3
    • OS: Ubuntu 16.04
    Client
    • Service Version: 0.11.12
    • OS: Windows 10 1703
    Description

    We’ve been creating a new Windows 10 image for the 1703 update. I have a strange issue when the test pc I have imaged boots to pxe and the fog menu. After the menu it boots to hard drive and does an error beep and won’t boot. Bypassing the pxe boot after image and booting straight to the hard drive works fine.

    The bios is set to legacy boot as it has been previously for the 1607 Windows update, which worked fine. Otherwise, the image is just a standard install, boot to Audit Mode, then install Fog and a couple of other bits of software and sysprep.

    Has anyone else come across this error?


  • Moderator

    @chief When you install the fog client msi, the fog service should be installed and running. Typically right after install I will manually stop the service and set it to not start on reboot. We don’t want the fog service starting to do its job of renaming the PC and connecting to the domain before the OOBE process has finished on the deployed target.

    The process is outlined here: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep

    Just for clarity does other systems (not this specific win10 1703) connect to AD correctly, its just 1703 giving you troubles?



  • I have been installing the FOGservice.msi before sysprep. This, I believe, doesn’t install the service until after reboot? Or the service isn’t there to disable.

    It is probably a separate issue, as the original issue from this post is resolved with the exit type setting.


  • Moderator

    @chief Do you have the fog client installed on the reference image before capture? Do you have it configured to be stopped during imaging and then use the setupcomplete.cmd to re-enable the fog client service?

    Your two issues are not necessarily connected.



  • Found the exit type option in the settings and set to GRUB_FIRST_HDD. This worked, but now the PC isn’t joining the domain.



  • Hi,

    that simply sounds like the wrong exit type for this machine. Try to use another exit type and report back.
    What is it for a computer and which type of exit type do you use?

    Regards X23


  • Moderator

    Since 1703 is new (Yeah I know its been out for a bit) MS may have changed the disk structure that the fog developers may not have anticipated. This is the second post in the FOG Forums in the past week that sounds similar with 1703. @x23piracy does this sound similar to your problem? (forgive me if you don’t have the similar issue)


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.