Error 500 in host edition


  • Moderator

    Server
    • FOG Version: 1.5.0-RC-8 ( SVN 6080)
    • OS: Debian 8.8 (PHP5)
    Description

    Hi,

    I can’t accces host information/edition.

    When I try to acces an url like that : http://myfogserver.com/management/index.php?node=host&sub=edit&id=605, I’ve an error 500.

    log :
    [Thu Aug 17 10:41:34.369187 2017] [:error] [pid 25461] [client 192.168.101.252:53261] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/fog/lib/plugins/accesscontrol/hooks/addaccesscontrolapi.hook.php on line 115
    [Thu Aug 17 10:41:34.424336 2017] [:error] [pid 25461] [client 192.168.101.252:53261] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/fog/lib/plugins/accesscontrol/hooks/addaccesscontrolapi.hook.php on line 115
    [Thu Aug 17 10:41:34.429048 2017] [:error] [pid 25461] [client 192.168.101.252:53261] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/fog/lib/plugins/accesscontrol/hooks/addaccesscontrolapi.hook.php on line 115
    [Thu Aug 17 10:41:38.578096 2017] [:error] [pid 25461] [client 192.168.101.252:53261] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32768 bytes) in /var/www/html/fog/lib/fog/fogcontroller.class.php on line 261

    I’ve tried ton increase memory in FOG and PhP (512M).

    I can list all host without problem.

    Ch3i


  • Moderator

    @tom-elliott said in Error 500 in host edition:

    That said is it just permissions of the user?

    Yep it’s for user rights, but I don’t use it, it was to try the plugin few month ago…


  • Senior Developer

    I’ve marked solved for now. I haven’t gotten to access control yet for GUI stuff. That said is it just permissions of the user?


  • Moderator

    I’ve disabled the accesscontrol plugin after plug in my brain…
    It’s solved my problem.


Log in to reply
 

412
Online

38970
Users

10712
Topics

101667
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.