SOLVED Failed to set guid, doesn't resize.

  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.04
    • Service Version: 0.11.15
    • OS: Windows 10 Enterprise

    Recently upgraded a FOG 1.3 installation to 1.4.4. Using the same images created with 1.3 now workstations start with the failed to set guid. Originally, it was a error and everything would stop at that point. The system would reboot and try to rerun the task because it failed to complete. Applying the init.xz files from thread 9948 ( changed it from an error to a warning. The task now completes and the units are not stuck in the reboot and reimage loop but the partitions never resize.

    I’ve searched the threads to no avail on how to correct this issue. Removing the d1.original.uuids causes the errors to go away but does not fix the resize issue. I’ve even re-pushed the image to the server with the .uuids missing, after the init.xz change, and it recreated the same problems.

    Thanks in advance!

  • Senior Developer

    @entr0py Tom was saying that there was an issue with resizing in 1.4.4, would you try out upgrading to the latest RC9 version and see if this is solved.

  • Senior Developer

    @entr0py Any news on this?

  • Senior Developer

    @entr0py What exactly do you mean by “…but the partitions never resize”? What exactly is the outcome after cloning the image to disk? You made sure the image type is set to resizable?

    Please post the contents of d1.minimal.partitions and d1.fixed_size_parts as well!

    From the picture you posted it looks as if there is an issue with the d1.original.uuids file. Please post the contents of this file too.

    Please read through this thread as well and pay attention to Tom’s last comment.

  • As an update, I created a new image, named the same thing with an extra character at the end. Changed my image master and one client to be the new image, captured and deployed and the results are the same. I can say it isn’t something being held over from the old image configuration from 1.3.


    label: gpt
    label-id: 3B297ACC-51F5-4B3A-8A67-2227339DA914
    device: /dev/nvme0n1
    unit: sectors
    first-lba: 2048
    last-lba: 500118158
    /dev/nvme0n1p1 : start=        2048, size=      921600, type=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC, uuid=A15FB31F-4441-488E-9456-89B9B7461E1F, name="Basic data partition"
    /dev/nvme0n1p2 : start=      923648, size=      202752, type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, uuid=5DF33B32-90B4-4D42-8B08-365B8DA0A994, name="EFI system partition"
    /dev/nvme0n1p3 : start=     1126400, size=       32768, type=E3C9E316-0B5C-4DB8-817D-F92DF00215AE, uuid=D2C44AF3-54B4-4A39-9E78-EEFB1F771027, name="Microsoft reserved partition"
    /dev/nvme0n1p4 : start=     1159168, size=   498958336, type=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7, uuid=28132F21-6D6D-4F0E-B09B-1FAFADFF097F, name="Basic data partition"

    p1, 2, and 3 are properly transferred and they are listed in fixed_size. It appears fog even thinks p4 actually resized properly but it never does.